iv1as2
?>

Даны три действительных числа. Вычислить корень квадратный из четных чисел и возвести во 2 степень нечетные числа. Задание необходимо выполнить в одной из доступных версий программы Pascal (PASCAL ABC.NET, PASCAL ABC, Turbo Pascal; допускается использование онлайн-компилятора

Информатика

Ответы

guzelda19904850
Uses Crt;
  const n=5; m=7;
  type Mas = array [1..n, 1..m] of integer;
  var i, j, j1, j2: integer;
      Sumj1, Sumj2: real;
      A: Mas;
begin
 ClrScr;
 Randomize;
 SumJ1:=0; SumJ2:=0;
 for i:=1 to n do
    for j:=1 to m do
    A[i,j]:=random (10);
 WriteLn (' Massiv A: ');
 for i:=1 to n do
   begin
      for j:=1 to m do
      Write (A[i,j]:4);
      WriteLn;
   end; WriteLn;
 repeat
   Write (' Stolbez #1 = ');    ReadLn(j1);
 until (j1>=1) and (j1<=m);
 repeat
   Write (' Stolbez #2 = '); ReadLn(j2);
 until (j2>=1) and (j2<=m) and (j1<>j2);
 for i:= 1 to n do
    SumJ1 := SumJ1+A[i,j1];
 for i:= 1 to n do
   SumJ2:=SumJ2+A[i,j2];
 SumJ1:=SumJ1/n; SumJ2:=SumJ2/n; 
WriteLn;
WriteLn (' Srednee stolbza ', j1, ' = ', SumJ1:4:2);
WriteLn (' Srednee stolbza ', j2, ' = ', SumJ2:4:2); 
ReadLn;
end.
Паскаль.составить программу, вычисляющую среднее значение по двум столбцам матрицы. номера столбцов

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны три действительных числа. Вычислить корень квадратный из четных чисел и возвести во 2 степень нечетные числа. Задание необходимо выполнить в одной из доступных версий программы Pascal (PASCAL ABC.NET, PASCAL ABC, Turbo Pascal; допускается использование онлайн-компилятора
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Anatolevich667
mail5
ganzashop
ann-perminova2008
Сергеевич1386
ecocheminnov437
Валентинович133
jaksonj326
RozaAsadullina
Андрееевич787
tarhan1221
Voronin-Albertovich
Blekjek730
соловьев_Куркина
kisuhakisa