Garifovich Greshilova791
?>

Используя цикл «for», написать программу на языке С++ для решения следующей задачи: Среди всех двузначных чисел найти количество таких, у которых сумма цифр кратна 3. Например, у числа 27 сумма цифр 2+7 = 9, т.е. кратна 3, а у числа 25 сумма цифр 2+5 = 7 не кратна 3. Определите, сколько чисел удовлетворяет задачи.

Информатика

Ответы

Шапкина1531

int sum = 0;

for (int i=10, i<=99, i++) {

if ((i%10 + i/10) % 3 == 0) {

sum += 1;

}

}

cout << sum;

Если есть вопросы по коду - пиши в комментарии

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Используя цикл «for», написать программу на языке С++ для решения следующей задачи: Среди всех двузначных чисел найти количество таких, у которых сумма цифр кратна 3. Например, у числа 27 сумма цифр 2+7 = 9, т.е. кратна 3, а у числа 25 сумма цифр 2+5 = 7 не кратна 3. Определите, сколько чисел удовлетворяет задачи.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

koam20167459
Anton661
AkulovaAnastasiya
Меладзе_Владимир1695
Серопян
ГазалиеваКозак
Напишите программу с векторов​
mzubenko6
serov555zaq5
brendacepedam
format-l3364
teya07
zotcet7
Batrakova-Anna
natkuv7
tochkamail7