Новиков1139
?>

Составить программу на Phyton, содержащую ветвления и определяющую, принадлежит ли точка с координатами (x, y) заштрихованной области

Информатика

Ответы

yurogov61

uses

   crt;

const

    max=50;

var

  a:array[1..max,1..max] of integer;

  i,j,n,s,k:integer;

begin

    writeln('wvedite razmernost matrici');

    readln(n);

    writeln('wvedite matricu ',n,' x ',n);

    for i:= 1 to n do

        begin

             for j:= 1 to n do

                 read(a[i,j]);

        end;

    s:=0;

    k:=0;

    for i:= 1 to n do

        begin

             for j:= 1 to n do

                 if (j mod 2<>0) and (i mod 2<>0) then

                    begin

                         s:=a[i,j]+s;

                         k:=k+1

                    end;

        end;

        s:=round(s/k);

        writeln('sredne arifmet znashenie s neshetnimi indeksami ravno ', s);

readkey

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на Phyton, содержащую ветвления и определяющую, принадлежит ли точка с координатами (x, y) заштрихованной области
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Oslopova
Busyashaa
nzagrebin363
Boss5519
Chistova-Dmitrii1162
Викторовна
tooltechnic
julianikaleksandrova
Bologova Golovach1989
avto3132
Кирилл-Анна1023
Galliardt Sergeevna1284
samsakovs7757
socofilesrus4
Калмыкова-Петрунина