Varezka86179
?>

Программа получает на вход последовательность целых неотрицательных чисел. Ноль – признак конца. Поменять местами минимальный и максимальный элементы. Если максимальных и/или минимальных элементов несколько, то брать в расчёт первое вхождение. Sample Input 1: 1 8 2 13 0 Sample Output 1: 13 8 2 1 Sample Input 2: 1 1 5 2 5 0 Sample Output 2: 5 1 1 2 5 Программу написать в Python.

Информатика

Ответы

Татьяна-Мария

n = int(input())

mass = []

mx = 0

mn = n

while n != 0:

   mass.append(n)

   if n > mx:

       mx = n

   if n < mn:

       mn = n

   n = int(input())

mass[mass.index(mx)], mass[mass.index(mn)] = mass[mass.index(mn)], mass[mass.index(mx)]

print(mass)

Объяснение:

замену максимума на минимум

mass[mass.index(mx)], mass[mass.index(mn)] = mass[mass.index(mn)], mass[mass.index(mx)]

можно записать так

i = mass.index(mx)

j = mass.index(mn)

mass[i], mass[j] = mass[j], mass[i]

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Программа получает на вход последовательность целых неотрицательных чисел. Ноль – признак конца. Поменять местами минимальный и максимальный элементы. Если максимальных и/или минимальных элементов несколько, то брать в расчёт первое вхождение. Sample Input 1: 1 8 2 13 0 Sample Output 1: 13 8 2 1 Sample Input 2: 1 1 5 2 5 0 Sample Output 2: 5 1 1 2 5 Программу написать в Python.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

petrova-kate3
dionissia2
Alnkseevna
dimari81
iracaenko153
Викторович
ooo-helpvet44
ver2bit
SERGEI124
sergey
skrepka397412
Павел_Перелыгин
mikek0906
Yurevich1243