?>
Дан массив a, состоящий из n целых неотрицательных чисел. Ваша задача — выписать его нечётные элементы на те же места во второй массив b того же размера, а остальные элементы массива b заполнить нулями. Формат входных данных В первой строке входных данных вводится натуральное число n (n≤500) — количество элементов массива. Во второй строке лежат n целых неотрицательных чисел, разделённых пробелами — элементы этого массива. Элементы массива не превосходят 1000. Формат выходных данных Выведите на экран n целых неотрицательных чисел, разделённых пробелами — элементы массива b. входные данные 4 1 3 3 7 5 4 20 412 3 2 выходные данные 1 3 3 7 0 0 0 3 0
Ответы
Объяснение:
#include <iostream>
#include <vector>
using namespace std;
int main()
{
int N;
cin >> N;
vector<int> a(N, 0);
for (int i = 0; i < N; i++) {
int b;
cin >> b;
if (b % 2 != 0)
a[i] = b;
}
for (int i = 0; i < N; i++)
cout << a[i]<<" ";
return 0;
}