gre4ka2004
?>

Информатика (Паскаль) № 1. Запишите значение переменной s, полученное в результате работы следующей программы.var s, k: integer; begin s := 0; for k := 4 to 7 do s := s + 8; writeln(s); end.№ 2. Запишите значение переменной s, полученное в результате работы следующей программы.var s, k: integer; begin s := 0; for k := 3 to 8 do s := s + 9; writeln(s); end.№ 3. Вычислить количество натуральных чисел от 1 до N. № 4. Написать программу вычисления произведения натуральных чисел от 12 до 14.​

Информатика

Ответы

sastakhova

Задача №1

Смотрим на цикл, при выполнении программы он пройдёт 4 итерации.

Тогда S = 8 * 4 = 32

ответ: 32

Задача №2

Смотрим на цикл, при выполнении программы он пройдёт 5 итераций.

Тогда сначала s = 1 * 2 = 2, потом s = 2 * 2 = 4, затем s = 4 * 2 = 8,  затем s = 8 * 2 = 16, затем s = 16 * 2 = 32,

ответ: 32

Задача №3

Здесь будет 11 итераций цикла, 100 - 5 * 11 = 45 (т.к. s = 100, за один проход - 5 от значения s)

ответ: 45

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Информатика (Паскаль) № 1. Запишите значение переменной s, полученное в результате работы следующей программы.var s, k: integer; begin s := 0; for k := 4 to 7 do s := s + 8; writeln(s); end.№ 2. Запишите значение переменной s, полученное в результате работы следующей программы.var s, k: integer; begin s := 0; for k := 3 to 8 do s := s + 9; writeln(s); end.№ 3. Вычислить количество натуральных чисел от 1 до N. № 4. Написать программу вычисления произведения натуральных чисел от 12 до 14.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kulibabad566
dentalfamily
Aleksandrovich-Mayatskikh
Aleksandr362
denis302007
Adabir20156806
olimov
bestxbox
shabunina17
araqsyabadalyan1988
s9152992722344
elena-novikova-1992
salahovta
mirogall