Поделитесь своими знаниями, ответьте на вопрос:
Задача по информатике. Нужно написать программу(язык Pascal) Ввести с клавиатуры строку символов. Выяснить: есть ли в строке цифры? Вывести отдельно на экран в обратном порядке эти цифры и подсчитать их сумму.
n=4; { количество разрядов (цифр) в числе }
var
a:array[1..n] of integer;
i,j,k:integer;
begin
Write('Введите ',n,'-значное число: '); Read(k);
for i:=1 to 4 do
begin a[i]:=k mod 10; k:=k div 10 end;
for i:=1 to n-1 do
for j:=i+1 to n do
if a[i]>a[j] then begin k:=a[i]; a[i]:=a[j]; a[j]:=k end;
Writeln('Наибольшая цифра ',a[n],', наименьшая цифра ',a[1],
', их разность ',a[n]-a[1])
end.
Тестовое решение:
Введите 4-значное число: 1421
Наибольшая цифра 4, наименьшая цифра 1, их разность 3