С клавиатуры вводят целые числа. Написать программу, которая рассчитывает сумму чисел больших 20; среднее арифметическое значение нечетных чисел. Количество чисел вводят с клавиатуры.
writeln('Среднее арифметическое ',ncount,' нечётных чисел =', nc/ncount:2:2);
end.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
С клавиатуры вводят целые числа. Написать программу, которая рассчитывает сумму чисел больших 20; среднее арифметическое значение нечетных чисел. Количество чисел вводят с клавиатуры.
на Free Pascal
Объяснение:
var
a : integer;
n, i, big, nc, ncount : integer;
begin
writeln('Введите количество чисел :');
readln(n);
big := 0;
nc := 0;
ncount := 0;
for i := 1 to n do begin
writeln('Введите ', i, ' число:');
readln(a);
if a>20 then
big := big + a;
if (a mod 2) <> 0 then begin
nc := nc + a;
inc(ncount);
end;
end;
writeln('Сумма чисел > 20 = ', big);
writeln('Среднее арифметическое ',ncount,' нечётных чисел =', nc/ncount:2:2);
end.