samiramoskva
?>

Составить программу DELPHI, которая вычисляет сумму нечётных чисел отрезка [a, b]. именно delphi!label 1 -введите Аlabel 2 -введите Blabel 3 -результатbutton 1 -вычислитьedit 1 -значение Аedit 2 -значение В​

Информатика

Ответы

Tarapovskaya
1. В приведенном коде ошибка. Не хватает ";" в третьей строке снизу.
2. Немного изменим ваш код и получим искомое значение x
Искомое число х = 16293

var
  x, y, a, b, k: integer;

begin
  k:=10000;
  repeat
    x:=k;
    a := 0; b := 0; y := 1;
    while x > 0 do
    begin
      if (x mod 10) mod 2 = 0
        then
        a := a * 10 + x mod 10
      else begin
        y := y * 10;
        b := b * 10 + x mod 10
      end;
      x := x div 10
    end;
    a := a * y + b;
    k := k + 1;
    until a = 26391;
    writeln(a:8, k-1:8); 
end.

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу DELPHI, которая вычисляет сумму нечётных чисел отрезка [a, b]. именно delphi!label 1 -введите Аlabel 2 -введите Blabel 3 -результатbutton 1 -вычислитьedit 1 -значение Аedit 2 -значение В​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Анна Марина1873
tretyakovamarina201155
snabdonm501
venera2611
larisau41
annanechaeva567
inj-anastasia8
rosik76
Anna572
sarycheva659
l250sp70
shhelina
chermen40
Pavlovna-Golovitinskaya378
andreevaanastsiyao82