peresvetoff100015
?>

Напишите программу, которая будет считывать с клавиатуры пароль и проверять соответствует ли введенный пароль требованиям и возвращает True, если соответствует и False, если нет. Пароль должен содержать: а) буквы (регистр не важен) б) как минимум одну цифру А также НЕ должен содержать пробелов.

Информатика

Ответы

ilonchick679

python

password  = input()

have_letter = False

have_diggit = False

have_space = False

for i in password:

 if i.isalpha():

   have_letter = True

 elif i.isdigit():

   have_diggit = True

 elif i == ' ':

   have_space = True

if have_letter and have_diggit and not have_space:

 print(True)

else:

 print(False)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая будет считывать с клавиатуры пароль и проверять соответствует ли введенный пароль требованиям и возвращает True, если соответствует и False, если нет. Пароль должен содержать: а) буквы (регистр не важен) б) как минимум одну цифру А также НЕ должен содержать пробелов.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

retropluse832
shilinmikhaillg
Belokonev286
mpityk
nurtilekisakov
yusovd291
nngudkova1970
mariokhab
Серопян
Инна_Nina1182
vnolenev
elenachuxina804
jstepanova
dilovarnazarov1986
randat887040