?>
Путешествуя на автомобиле, вы заехали на автозаправочную станцию. До следующей заправки 200 километров. Напишите программу, которая будет определять, нужно ли вам заправляться или можно подождать до следующей станции. Программа должна спросить: какой размер вашего бензобаке в литрах; сколько горючего в бензобаке (в процентах); сколько километров проходит автомобиль на одном литре топлива. результатом работы программы должна быть информация о количестве километров, которые еще можно проехать и подождать до следующей автозаправочной станции, или немедленно заправиться.
Ответы
begin
var s:=ReadInteger('n=').ToString.JoinIntoString('');
Writeln('Цифр в числе- ',s.Length);
Writeln('Сумма цифр- ',s.Select(d->Integer.Parse(d)).Sum);
Writeln('Последняя цифра- ',s.Last);
Writeln('Первая цифра- ',s.First);
Writeln('Предпоследняя цифра- ',s[s.Length-1]);
var m:=ReadInteger('m=');
Write('Сумма ',m,' последних цифр числа- ');
Writeln(s.Skip(s.Length-m).Select(d->Integer.Parse(d)).Sum);
Write('Цифра 3 в запись числа ');
if Pos('3',s)>0 then Writeln('входит')
else Writeln('не входит');
Writeln('Число в обратном порядке- ',s.Reverse.JoinIntoString(''));
Writeln('Перестановка первой и последней цифр- ',
s.Last+Copy(s,2,s.Length-2)+s.First);
end.
Тестовое решение:
n= 1063
Цифр в числе- 4
Сумма цифр- 10
Последняя цифра- 3
Первая цифра- 1
Предпоследняя цифра- 6
m= 2
Сумма 2 последних цифр числа- 9
Цифра 3 в запись числа входит
Число в обратном порядке- 3601
Перестановка первой и последней цифр- 3061