// PascalABC.NET 3.0, сборка 1150 от 22.01.2016 begin var n:=ReadInteger('Количество элементов массива '); var m:=ArrRandom(n,-50,50); m.Println(', '); var a:=0; var b:=0; var c:=0; for var i:=0 to n-1 do begin if m[i]>0 then a:=a+m[i]; if m[i]<m[b] then b:=i; if m[i] mod 5 = 0 then Inc(c) end; var w:=(b+1)+a/(c+1); WritelnFormat('A={0}, B={1}, C={2}, W={3}',a,b+1,c,w); Writeln('Принято, что элементы массива нумеруются от единицы') end.
Тестовое решение: Количество элементов массива 13 -43, -15, 18, -8, -13, -47, -36, 6, -16, 45, 33, 33, -24 A=135, B=6, C=2, W=51 Принято, что элементы массива нумеруются от единицы
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу вычисления значения функции F при любых целых a, b, c: F=3•a - корень из c+a | b²-81|
begin
var n:=ReadInteger('Количество элементов массива ');
var m:=ArrRandom(n,-50,50); m.Println(', ');
var a:=0; var b:=0; var c:=0;
for var i:=0 to n-1 do begin
if m[i]>0 then a:=a+m[i];
if m[i]<m[b] then b:=i;
if m[i] mod 5 = 0 then Inc(c)
end;
var w:=(b+1)+a/(c+1);
WritelnFormat('A={0}, B={1}, C={2}, W={3}',a,b+1,c,w);
Writeln('Принято, что элементы массива нумеруются от единицы')
end.
Тестовое решение:
Количество элементов массива 13
-43, -15, 18, -8, -13, -47, -36, 6, -16, 45, 33, 33, -24
A=135, B=6, C=2, W=51
Принято, что элементы массива нумеруются от единицы