hvostna23
?>

Написать программу, где пользователь вводит с клавиатуры радиус окружности(float вычислить и вывести длину окружности(формула 1=2πr, записывается pi)нужно написать в питоне ​

Информатика

Ответы

rada8080

Ну начнем с того, что твоя функция ничего не возвращает, она выводит на экран информацию. Второй косяк в том, что функция isdigit() проверяет всю строку, то есть, при строке с одними цифрами твоя программа даст верный ответ.

Исправить максимально просто, нам нужно проверить каждый символ строки, если встречаем хоть 1 цифру, то возвращаем true, а если не встретим в строке цифр - false.

Максимально простой вариант для новичка, скорее всего, такой:

def number(x):

  for i in x:

      if i.isdigit():

          return True

  return False

print(number('xx'))

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, где пользователь вводит с клавиатуры радиус окружности(float вычислить и вывести длину окружности(формула 1=2πr, записывается pi)нужно написать в питоне ​
Ваше имя (никнейм)*
Email*
Комментарий*