a8227775
?>

массив содержит чёткое количество элементов напишите программу которая сортирует первую половину массива по возрастанию а вторую по убыванию каждый элемент должен остаться в своей половине питон​

Информатика

Ответы

Fedorovna

Python

from random import randint

n=int(input('Введите количество элементов массива : '))

if n%2!=0:

 n=n+1

a=[0]*n

for i in range (0, n):

 a[i]=randint(1,100)

 

print(a)

i=0

k=0

# сортируем первую часть массива по возрастанию

while i< n//2-1:

 if a[i]>a[i+1]:

     k=a[i]

     a[i]=a[i+1]

     a[i+1]=k

     i=-1

 i +=1

# сортируем вторую часть массива по убыванию

while i < n-1:

 if a[i]<a[i+1]:

     k=a[i]

     a[i]=a[i+1]

     a[i+1]=k

     i=n//2-1

 i +=1

 

print(a)  


массив содержит чёткое количество элементов напишите программу которая сортирует первую половину мас

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

массив содержит чёткое количество элементов напишите программу которая сортирует первую половину массива по возрастанию а вторую по убыванию каждый элемент должен остаться в своей половине питон​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

cat2572066
ivshzam
Gera8061
airlineskozlova69
frdf57
Volochaev
missbuhgalter2013
admin8808
Раисовна878
lyubavalev8
Михайлович Гуртовая929
keshka12719
mirdetzhuk79
mishagoride885
iriska-669