Стародубцева_Васильевич485
?>

Python Написать программу «Династия», в которой хранятся сведения о родственных связях сын-отец (не менее 10 пар значений Предполагается, что у каждого отца только один сын-наследник (например, представители царской династии). Программа должна уметь определять, кто отец заданного представителя династии и кто его дед (предусмотреть обработку ошибочного ввода и отсутствия деда). Python

Информатика

Ответы

kononenko-elena4
#include <iostream>
#include <list>

using namespace std;

int main() {
    list<int>mylist;
    //Делаем со списком, что хотим
    mylist.push_back(1);
    mylist.push_back(2);
    mylist.push_back(3);
    mylist.push_back(-4);
    mylist.push_back(5);
    for (auto i : mylist) {
        cout << i << " ";
    }
    cout << "\n";
    //Удаляем последний отрицательный элемент
    auto it = mylist.end();
    while (*it > 0) {
        if (it == mylist.begin()) {
            cout << "Not found.\n";
            return 0;
        }
        it--;
    }
    //Делаем со списком, что хотим
    mylist.erase(it);
    for (auto i : mylist){
        cout << i << " ";
    }
    return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python Написать программу «Династия», в которой хранятся сведения о родственных связях сын-отец (не менее 10 пар значений Предполагается, что у каждого отца только один сын-наследник (например, представители царской династии). Программа должна уметь определять, кто отец заданного представителя династии и кто его дед (предусмотреть обработку ошибочного ввода и отсутствия деда). Python
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

matoksana
Anna-Miron
tatyana58
Gavrilova2527
opel81
Vladimirovna Yevtodeva
prohorovalena
GridnevaVNIGNI&quot;
volodinnikolay19
lionmost6979
AnnaChulyukanova3
AMR89154331531
Марина_Мария
innaterenina
ostapbender1111