gabramova
?>

4. Напишите программу, которая выводит на экран значения функции y= f(x Аргумент x принимает значения от x1 до х2 с шагом Дх:{y = {3 – x; x > 4; 3 + x, x<4;​

Информатика

Ответы

Vladimirovna Viktorovna
Попробуй Program PascalGuru; var s:string;    f,t:text;
function preobr(s:string):string;var i,j,p,n,sered:integer;    gl,zp,slovo:string;    m:array [1..80] of string;beginzp:='!?*,.'; gl:='аоуыэяеёюи';  p:=pos(' ',s); i:=0;        repeat        inc(i);        slovo:=copy(s,1,p-1);        m[i]:=slovo;        delete(s,1,p);        p:=pos(' ',s);        until p=0;        n:=i+1;        m[n]:=s;    for i:=1 to n do     begin    s:=m[i];       if pos(s[length(s)],zp)<>0 then p:=length(s)-1 else p:=length(s);     sered:=(p div 2)+1;    if (not odd(p)) or (p<3) then continue;     if pos(s[1],gl)=0       then continue;     if pos(s[sered],gl)=0   then continue;     if pos(s[p],gl)=0       then continue;      s[1]:=UpCase(s[1]);    s[sered]:=UpCase(s[sered]);    s[p]:=UpCase(s[p]);     m[i]:=s+'('+s[1]+','+s[sered]+','+s[p]+')';     end;         s:='';     for i:=1 to n do s:=s+m[i]+' '; preobr:=s;end;
 beginassign(f,'input.txt'); reset(f);assign(t,'output.txt'); rewrite(t); while not eof(f) do      begin      readln(f,s);      writeln(t, preobr(s) );      end;  writeln('Файл успешно записан...'); close(f);close(t);readln;end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

4. Напишите программу, которая выводит на экран значения функции y= f(x Аргумент x принимает значения от x1 до х2 с шагом Дх:{y = {3 – x; x > 4; 3 + x, x<4;​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

krasnova1977
solonataly5
Маринова
hvostna23
pisikak999
сергеевич1958
avolodyaev
MaratФам
zdanovich90764
rina394992
Баканова1415
Vyacheslavovna240
e-liza-k
ВладимировнаАлександр1421
plv-57