Аношкина1696
?>

Составить программу для определения таблицы значений функции у в произвольном диапазоне [a, b] изменения аргумента с произвольным h, вводимым с клавиатуры. Таблица должна солержать следующие столбцы: порядковый номер, значение аргумента х, значение функции, сообщение о возрастании или убывании функции, разность двух соседних значений функции. Определить максимальное и минимальное значения функции. сделать на dev-c++

Информатика

Ответы

sharikplushelen
#include <iostream>
#include <cstdlib>
#include <ctime>
int main()
{
    using namespace std;
    const int n = 10;  //количество элементов массива
    int Arr[n];

    //как-нибудь заполняем массив
    srand(time(0));
    int i;
    for (i = 0; i < n; ++i)
        Arr[i] = rand() % (n * n) + 1;

    //выведем его на экран
    for (i = 0; i < n; ++i)
        cout << Arr[i] << "   ";
    cout << endl;

    int p;
    for (i = 1; i < n; ++i)
    {
        p = i;
        while (p % 2 == 0)
            p /= 2;
        if (p == 1)
            cout << "Arr[" << i << "] = " << Arr[i] << endl;
    }
    cout << endl;
    return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для определения таблицы значений функции у в произвольном диапазоне [a, b] изменения аргумента с произвольным h, вводимым с клавиатуры. Таблица должна солержать следующие столбцы: порядковый номер, значение аргумента х, значение функции, сообщение о возрастании или убывании функции, разность двух соседних значений функции. Определить максимальное и минимальное значения функции. сделать на dev-c++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Bella
borisovaks496
efimov33
ksv89
Butsan-Bagramyan
Novikova Aleksandrovna
maksimforyou20
Kashirina
avdeevo
Smirnovav1982422
An-solomon
Сопова
petria742
osipov1984osipov
grebish2002
▲