rozhkova
?>

Напишите программу, которая получает с клавиатуры два числа, одно из которых может не быть целым, и вычисляет их произведение, используя только операции сложения. Учтите, что числа могут быть отрицательными. Напишите программу, которая заполняет список пятью словами с клавиатуры, считает длину каждого слова и добавляет эти числа в другой список. Программа заканчивается выводом обоих списков, каждый в строку, но в разных абзацах.Программа получает с клавиатуры длинное целое число и подсчитывает, сколько раз в его записи встречается заданная пользователем цифра.Работа в пайтоне.нужно одну задачу решить очень надо ​

Информатика

Ответы

Konstantinovich alekseevna993
Function Sq(a,b,c:real):real;
Var p:real;
Begin
p:=(a+b+c)/2;
result:=Sqrt(p*(p-a)*(p-b)*(p-c))
End;

Function Tr(a,b,c:real):boolean;
Begin
result:=(a+b>c)and(a+c>b)and(b+c>a)
End;

Var
a,b,c,k1,k2,h,t,s,r1,r2:real;
Begin
writeln(' найти радиус или площадь треугольника? если радиус,то нажмите 1. Если площадь, то нажмите 2 ');
readln(k1);
if k1=1 then 

 begin 
 writeln('окружность вписанная(нажмите 1) или описанная(нажмите 2)?');
 readln(k2);

 write('сторона а = ');
 readln(a);
 write('сторона b = ');
 readln(b);
 write('сторона с = ');
 readln(c);
 if Tr(a,b,c) then
  begin
  s:=Sq(a,b,c);

  if k2=1 then 
  begin
  r1:=(a+b+c)/(2*s);
  writeln('радиус вписанной окружности = ' , r1);
  end;

  if k2=2 then 
  begin
  r2:=a*b*c/(4*s);
  writeln('радиус описанной окружности = ', r2);
  end;
  end else WriteLn('Треугольник не существует');
 end
else

 if k1=2 then
 begin
 writeln('что вам известно? если а и h, то нажмите 1. если а,b,с то нажмите 2' );
 readln(k2);
 if k2=1 then
  begin
  write('высота = ');
  readln(h);
  write('cторона = ');
  readln(t);
  s:=1/2*h*t;
  writeln('площадь = ',s);
  end;

  if k2=2 then
  begin
  Write('a = ');
  ReadLn(a);
  Write('b = ');
  ReadLn(b);
  Write('c = ');
  ReadLn(c);
  if Tr(a,b,c) then
   begin
   s:=Sq(a,b,c);
   writeln('площадь = ',s) ;
   end else WriteLn('Треугольник не существует');
  end;
 end;
end.

Пример:
 найти радиус или площадь треугольника? если радиус,то нажмите 1. Если площадь, то нажмите 2 
2
что вам известно? если а и h, то нажмите 1. если а,b,с то нажмите 2
1
высота = 3
cторона = 4
площадь = 6

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая получает с клавиатуры два числа, одно из которых может не быть целым, и вычисляет их произведение, используя только операции сложения. Учтите, что числа могут быть отрицательными. Напишите программу, которая заполняет список пятью словами с клавиатуры, считает длину каждого слова и добавляет эти числа в другой список. Программа заканчивается выводом обоих списков, каждый в строку, но в разных абзацах.Программа получает с клавиатуры длинное целое число и подсчитывает, сколько раз в его записи встречается заданная пользователем цифра.Работа в пайтоне.нужно одну задачу решить очень надо ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

stasyan
Shirochkingames
ЮлияДаниил520
qwqwweqw3
delo1005
nsoro937
annapiskun1
aniramix
annakorolkova79
kchapurina591
maisa1991
zvanton
jim2k
allo01
Vladimirovna Yevtodeva