Поделитесь своими знаниями, ответьте на вопрос:
За контрольную работу в классе учениками было получено A - пятерок, B - четверок, C - троек и D - двоек Напишите программу, которая определяет сколько учеников получили оценку, превышающую средний Входные данные: на вход программы подаются 4 числа (A, B, C, D), по одному в строке Выходные данные: выведите одно число - сколько учеников получили оценку превышающую средний Входные данные: 10, 6, 2, 3 Выходные данные: 10 ПИТОН! ЗАРАНЕЕ
Программа
Объяснение:
Python 3
a=int(input())
b=int(input())
c=int(input())
d=int(input())
n=0
s=(a*5+b*4+c*3+d*2)/(a+b+c+d)
if 3>s: n+=a+b+c
elif 4>s: n+=a+b
elif 5>s: n+=a
print(n)
PascalABC
program n1;
var a, b, c, d, n: integer;
s: real;
begin
readln(a, b, c, d);
n:=0;
s:=(a*5+b*4+c*3+d*2)/(a+b+c+d);
if 3>s then n:=n+a+b+c
else if 4>s then n:=n+a+b
else if 5>s then n:=n+a;
writeln(n);
end.