Поделитесь своими знаниями, ответьте на вопрос:
1) Составьте программу, в которой продавец спросит у Вас, сколько шоколадок и по какой цене Вы собираетесь купить, и назовет Вам стоимость вашей покупки. 2) Составьте программу, в которой компьютер запросит у Вас ввести любое число от 1-9. После выведет таблицу умножения на указанное число
ВСЕ ЗАДАЧИ В ОДНОЙ
var enter,numberDgigits,i,j,cod,k:integer;
number:string;
ch:char;
begin
writeln('введите целое число');
readln(number);
for i:=1 to length(number)-1 do
if number[i]=number[i+1] then
k:=k+1;
if k<>0 then begin
writeln('в записи числа есть две одинаковые цифры стоящие рядом');
end
else
writeln('в записи числа нету двух одинаковых цифр стоящих рядом');
k:=0;
for i:=1 to length(number)-1 do begin
ch:=number[i];
for j:=1+i to length(number) do
if ch=number[j] then
k:=k+1;
end;
if k<>0 then begin
writeln('в записи числа есть одинаковые цифры');
end
else
writeln('в записи числа нету одинаковых цифр');
val(number,enter,cod);
if (enter>99) and (enter<1000) then begin
writeln('число трехзначное')
end
else
writeln('число не трехзначное');
numberDgigits := 0;
while enter > 0 do begin
numberDgigits := numberDgigits + enter mod 10;
enter := enter div 10;
end;
writeln('сумма цифр = ',numberDgigits);
readln;
end.