det-skazka55
?>

Решить на паскале: 1) Написать программу для ввода n пар натуральных чисел, из которых выбрать максимальное значения из каждой пары и посчитать сумму максимальных значений. На экран вывести список выбранных значений и сумму. Программу написать с использованием функции.2) Написать программу подсчета количества четных и нечетных цифр 10 значного натурального числа. Программу написать с использованием процедуры, принимающей и возвращающей значения.3) Написать программу для определения, является ли треугольник прямоугольным по трем введенным значениям длин его сторон. Программу написать с использованием процедуры без явного ввода значений и вывода (возврата) результата из процедуры .4) Написать программу для ввода n пар чисел, из которых выбрать максимальное значения из каждой пары и посчитать сумму максимальных значений, при том так, чтобы четность суммы совпадала с четностью большинства выбранных чисел. (Если четность не совпадет, то выбрать число другой четности из пары с минимальной разностью значений На экран вывести количество четных и нечетных чисел и максимальную сумму.

Информатика

Ответы

Melnik Kaveshnikova1746
Var x:real; n:integer;
begin
write('x = ');
readln(x);
writeln('Введите номер задачи:');
writeln('1-вычисление квадратного корня;');
writeln('2-возведение в квадрат;');
writeln('3-вычисление синуса;');
writeln('4-вычисление косинуса;');
readln(n);
case n of
 1: writeln(sqrt(x):6:4);
 2: writeln(x*x:6:4);
 3: writeln(sin(x):6:4);
 4: writeln(cos(x):6:4);
 else writeln('Ошибка ввода');
end;
end.

Пример:
x = 2.1
Введите номер задачи:
1-вычисление квадратного корня;
2-возведение в квадрат;
3-вычисление синуса;
4-вычисление косинуса;
3
0.8632

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить на паскале: 1) Написать программу для ввода n пар натуральных чисел, из которых выбрать максимальное значения из каждой пары и посчитать сумму максимальных значений. На экран вывести список выбранных значений и сумму. Программу написать с использованием функции.2) Написать программу подсчета количества четных и нечетных цифр 10 значного натурального числа. Программу написать с использованием процедуры, принимающей и возвращающей значения.3) Написать программу для определения, является ли треугольник прямоугольным по трем введенным значениям длин его сторон. Программу написать с использованием процедуры без явного ввода значений и вывода (возврата) результата из процедуры .4) Написать программу для ввода n пар чисел, из которых выбрать максимальное значения из каждой пары и посчитать сумму максимальных значений, при том так, чтобы четность суммы совпадала с четностью большинства выбранных чисел. (Если четность не совпадет, то выбрать число другой четности из пары с минимальной разностью значений На экран вывести количество четных и нечетных чисел и максимальную сумму.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Chuhnin195107364
Ignateva737
reception
gusrva3001
tcmir
verkop9
osipovasalex5316
alex091177443
merzlikinairena
Bogataya Vladimir318
Yevgenevna
Андрееевич787
anovikovsr
Railyan
Gennadievna bessonov