РостиславовичЮлия1147
?>

Нужна ПРОФИ 1) На вход алгоритма подается 125 целых чисел. Необходимо написать программу, которая будет выводить на экран число, которое в 4 раза больше среднего арифметического этих чисел из которого вычли число, которое в 2 раза больше минимального. 2) Рассматривается диапазон чисел от 1235 до 12346. Необходимо написать программу, которая в этом диапазоне будет находить среднее арифметическое чисел этого диапазона, но только тех, которые делятся на 3 и на 6, оканчиваются на 9 и не делятся на 9, 5 и 4. 3) На вход алгоритма поступают положительные целые числа. Сколько чисел – неизвестно, известно лишь то, что прием чисел заканчивается при поступлении на вход отрицательного числа. Необходимо написать программу, которая будет выводить на экран разность между средним арифметическим последовательности введенных чисел и числом, которое больше минимального этой же последовательности. Далее к получившемуся таким образом числу необходимо прибавить результат следующего выражения: (238*6x + 1F16*2y) – (1100112*x + 335*7y), где x = 410, y=210. Получившееся число необходимо также вывести на экран.

Информатика

Ответы

morozova4956

1)a=[1,2,3,4,5,6,7,8,9,10]

printsum(a)/len(a))-min(a)*2)*4))

2)

a=[a for a in range (1235,12347) if a%3==0 and a%10==9 and a%9!=0 and a%5!=0 and a%4!=0]

for i in a:

   if i%6==0:

       print('кратные 6 ', i) #можешь посмотреть, тут ничего не выведется

print(sum(a)/len(a))

Объяснение:

1)допиши это вместо готового списка

a=[]

for i in range(125):

   a.append(int(input()))

2) там нет числе, удовлетворяющих все условия. (я исключила условие с 6)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужна ПРОФИ 1) На вход алгоритма подается 125 целых чисел. Необходимо написать программу, которая будет выводить на экран число, которое в 4 раза больше среднего арифметического этих чисел из которого вычли число, которое в 2 раза больше минимального. 2) Рассматривается диапазон чисел от 1235 до 12346. Необходимо написать программу, которая в этом диапазоне будет находить среднее арифметическое чисел этого диапазона, но только тех, которые делятся на 3 и на 6, оканчиваются на 9 и не делятся на 9, 5 и 4. 3) На вход алгоритма поступают положительные целые числа. Сколько чисел – неизвестно, известно лишь то, что прием чисел заканчивается при поступлении на вход отрицательного числа. Необходимо написать программу, которая будет выводить на экран разность между средним арифметическим последовательности введенных чисел и числом, которое больше минимального этой же последовательности. Далее к получившемуся таким образом числу необходимо прибавить результат следующего выражения: (238*6x + 1F16*2y) – (1100112*x + 335*7y), где x = 410, y=210. Получившееся число необходимо также вывести на экран.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

maltes
Vuka91
olartamonov6
иванович Диденко1524
сергеевич1958
sav4ukoxana7149
Svetlana1877
westgti77105
uisfbu7777733
Voronov434
guujuu
oknacrow
lider-mpl550
fedoseevalyubov
menametov