nsn-2012
?>

Написать программу, используя массивы. Дана матрица размера NхM. Найти суммы элементов всех ее четных строк. python

Информатика

Ответы

kirillprotopopov1

1)

program pr;
uses crt;
Var y,x:real;

Begin
 Writeln('vvedite x');
 readln(x);
 y:=(4*x)/(x-1);
 Writeln('y=',y:10:3);
  readln;
end.

 

 

2)

program pr;

Var n,i,a:integer;

Begin
Writeln('введите кол-во цыфр');
readln(n);

for i:=1 to n do Begin
readln(a);
if (a>9) and (a<1000) and (a mod 10=4) then Writeln(a);
end;

end.

 

 

2) использование массива

 

program pr;
uses crt;
Var n,i:integer;
    a:array[1..100] of integer;
Begin
Writeln('Введите кол-во цифр');
readln(n);

Writeln('Введите цифры');
for i:=1 to n do read(a[i]);
Writeln;
for i:=1 to n do
if (a[i]>9) and (a[i]<1000) and (a[i] mod 10=4) then Write(a[i],';');

end.

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, используя массивы. Дана матрица размера NхM. Найти суммы элементов всех ее четных строк. python
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yorestov
Вакуленко
fucingprinces30
gorushko-tabak3
Ольга
dawlatowajana
Артур1807
АлександрАлина
mali2681208
alexanderpokrovskij6
helenavalenti2846
ams-sim
Измайлова-Алексей
Goldaram84
Andrei Morozov
▲