sawa-msk
?>

Исполнитель Март21 преобразует число на экране. У исполнителя есть три команди которым присвоены номера: 1. Прибавить 1 2. Прибавить 2 3. Прибавить 3 Сколько существует программ, для которых при исходном числе 4 результатом является число 21 и при этом траектория вычислений содержит число 7 и не содержит число 13? Введите целое число или десятичную дробь... За правильный ответ

Информатика

Ответы

yugraspets
Var
  i,j,n:integer;
  m: array[1..10,1..10] of integer;
  flag:boolean;
  sum: array[0..1] of longint;
 begin
  readln(n);
  flag:=true;
  for i:=1 to n do
   begin
    for j:=1 to n do
     read(m[i,j]);
    readln;
   end;
     //Проверяем строки
  i:=1;
  for j:=1 to n do
      sum[i mod 2]:=sum[i mod 2]+m[i,j];
  while ((i<n) and flag) do
    begin
     i:=i+1;
     for j:=1 to n do
      sum[i mod 2]:=sum[i mod 2]+m[i,j];
     if sum[0]<>sum[1] then flag:=false;
     sum[(i+1) mod 2]:=0;
    end;
    //Проверяем столбцы
  sum[0]:=0;
  sum[1]:=0;
  j:=1;
  for i:=1 to n do
      sum[j mod 2]:=sum[j mod 2]+m[i,j];
  while ((j<n) and flag) do
    begin
     j:=j+1;
     for i:=1 to n do
      sum[j mod 2]:=sum[j mod 2]+m[i,j];
     if sum[0]<>sum[1] then flag:=false;
     sum[(j+1) mod 2]:=0;
    end;
  sum[0]:=0;
  sum[1]:=0;
  j:=1;
  for i:=1 to n do
   begin
    sum[0]:=sum[0]+m[i,j];
    sum[1]:=sum[1]+m[n-i+1,j];
    j:=j+1;
   end;
  if  sum[0]<>sum[1] then flag:=false;
  if flag then writeln('Магический');
 end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Исполнитель Март21 преобразует число на экране. У исполнителя есть три команди которым присвоены номера: 1. Прибавить 1 2. Прибавить 2 3. Прибавить 3 Сколько существует программ, для которых при исходном числе 4 результатом является число 21 и при этом траектория вычислений содержит число 7 и не содержит число 13? Введите целое число или десятичную дробь... За правильный ответ
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mariashapar
yamal-toy
rudakovam198
osherbinin
topsalon
Валерия Воробьева396
meteor90
irschacha
arch5050
muzeynizhn
Kashtanov Anna
mvv-155
Sofinskaya1185
krispel9
aza2103