knigi21212
?>

Кто разбирается в PYTHON решите задачу Обработка текста Напишите программу для обработки текста. На вход вашей программы подаётся многострочный текст, причём число строк заранее неизвестно. Ваша задача – пронумеровать слова в нём, начиная с нуля, а затем вывести только те слова, которые начинаются с большой буквы. Перед словом необходимо вывести номер первого вхождения этого слова в текст. Слова необходимо отсортировать в лексикографическом порядке. Формат ввода Несколько строк текста. Формат вывода Номер первого вхождения этого слова в текст и само слово, разделённые дефисом. Примечания Для решения этой задачи вам итератор enumerate.

Информатика

Ответы

BelyaevNadezhda223

2-ое задание:

#include <iostream>

int main() {

int number;

std::cout << "Введите число: " << std::endl;

std::cin >> number;

if (number > 0)

 std::cout << "Положительное" <<std::endl;

else if (number < 0)

 std::cout << "Отрицательное" << std::endl;

else

 std::cout << "Ноль" << std::endl;

return 0;

}

1-ое задание:

#include <iostream>

int main() {

double dollars, grivnas;

std::cout << "Введите кол-во долларов: " << std::endl;

std::cin >> dollars;

grivnas = dollars * 28.3;

std::cout << dollars << " доллар-(а, ов) в гривнах " << grivnas << std::endl;

return 0;

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Кто разбирается в PYTHON решите задачу Обработка текста Напишите программу для обработки текста. На вход вашей программы подаётся многострочный текст, причём число строк заранее неизвестно. Ваша задача – пронумеровать слова в нём, начиная с нуля, а затем вывести только те слова, которые начинаются с большой буквы. Перед словом необходимо вывести номер первого вхождения этого слова в текст. Слова необходимо отсортировать в лексикографическом порядке. Формат ввода Несколько строк текста. Формат вывода Номер первого вхождения этого слова в текст и само слово, разделённые дефисом. Примечания Для решения этой задачи вам итератор enumerate.
Ваше имя (никнейм)*
Email*
Комментарий*