agaltsova86
?>

5. Продолжите предложение, по созданию ШАРА в программе SketchUp Make. Для создания шара в программе SketchUp Make из кладки выберите инструменты нарисуйте круг и расположите его вертикально. (36)

Информатика

Ответы

мария Кузив1393
В принципе, можно расписать, что делает эта программа (см. вложение). Так как изначально a[6] = 0, то a[3] = 50 раз к a[5] прибавится 2 * a[4] = 38, получится 38 * 50 + a[5] = 1917, затем значение a[5] будет выведено на экран.

Но проще не мучиться и просто написать программу, выполняющую этот код.

python 3.
array = [10, 330, 50, 19, 17, 0, 184, 0]
array_position = 2
program = "[->[->+>+<<]>>[-<+<+>>]<<<]>>."

stack = []
transitions = [None] * len(program)
for k, op in enumerate(program):
    if op == '[':
        stack.append(k)
    elif op == ']':
        v = stack.pop()
        transitions[k] = v + 1
        transitions[v] = k + 1
 
k = 0
while k < len(program):
    op = program[k]
    if op == '.':
        print(array[array_position])
    elif op == '>':
        array_position += 1
    elif op == '<':
        array_position -= 1
    elif op == '[' and array[array_position] == 0:
        k = transitions[k]
        continue
    elif op == ']' and array[array_position] != 0:
        k = transitions[k]
        continue
    elif op == '+':
        array[array_position] += 1
    elif op == '-':
        array[array_position] -= 1
    k += 1
Петя и вася придумали язык программирования мозг. в нём используются 8 ячеек памяти, и есть следую

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

5. Продолжите предложение, по созданию ШАРА в программе SketchUp Make. Для создания шара в программе SketchUp Make из кладки выберите инструменты нарисуйте круг и расположите его вертикально. (36)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Neveselova
dionissia2
mustaev
Kondratchik Vladimir
zaalmix
Андрееевич787
Emasterova77
NarekAlekseevich779
orion-inginiring7807
Хасанбиевич Колесников716
Volkovapavel
waspmoto6188
Devaunka40
Maksim Lokhov
bufetkonfet53