verakmves
?>

Написать программу, выводящую на экран значение Y, при заданном пользователем значении X:Y=^(X+25/10)+ SIN (π/2+X2)

Информатика

Ответы

gena1981007

1

var

mas:array[1..100] of integer;

i,n:integer;

en,out:text;

res:real;

qw,qwe:string;  

begin

 n:=0;

 i:=1;

 write('Введите полный путь к импортируемому файлу: ');readln(qw);

 write('Введите полный путь к экспортируемому файлу: ');readln(qwe);

 assign(en,qw+'.txt'); assign(out,qwe+'.txt');  

 reset(en); rewrite(out);

 while not Eof(en) do    

 begin

 readln(en,mas[i]);      

 n:=n+mas[i];                

 inc(i);        

 end;

   res:=(n/(i-1));  

   write(out,res);  

   close(out);      

   close(en);

 end.

Там во вторую тупо добавляешь:

 max:=-100001;

 min:=100001;

if (mas[i]<0) and (mas[i] mod 2 = 0) and (mas[i]<min) then min:=mas[i];

 if (mas[i]>0) and (mas[i] mod 2 = 1) and (mas[i]>max) then max:=mas[i];  

if (max=-100001)or(min=100001) then writeln(out,'ERROR: please, rewrite yor file')

 else  

 begin

   writeln(out,min);

   writeln(out,max);  

Тоже такие же задачи решал)) лол). Ты не из 604??)))

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, выводящую на экран значение Y, при заданном пользователем значении X:Y=^(X+25/10)+ SIN (π/2+X2)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

delo1005
tanyashevvvv
FATAHOVAMAINA
Ioanova Korneeva1093
Popov Valentina1324
chaa140
mihalewanadia20176987
kapi30
elmira01048775
delfa-r6289
pavelvsk2023
vova00831
miha23727
Узлиян Фурсов1488
Абдулганиева Сергей
▲