moskwa999
?>

оба задания 1) упорядочить одномерный вещественный массив из 20 элементов по убыванию методом перебора. 2) Сформировать вещественную матрицу 5х5. Вычислить произведение отрицательных элементов, находящихся над и под главной диагональю матрицы. Язык С++

Информатика

Ответы

elbabitch2014
Летающий автобус)
1. Мест в эконом-классе 120, а в бизнес-классе 40.
2. 100 процентов прибыли получим, если заполним все места. Билет в эконом-классе стоит в 2 раза меньше чем X. Получаем следующее уравнение:
40*X + 0.5*120*X = 100%, X = 1% от всей прибыли.  Значит один билет в бизнес - классе приносит один процент прибыли. А один билет в эконом-классе приносит 0.5 процента прибыли.
3. Осталось рассчитать прибыль компании учитывая непроданные билеты:
P = 100 - b - 0.5*a  и написать программу:

var a,b:integer;
begin
  repeat
    writeln('Введите количество непроданных билетов (a,b)');
    readln(a,b);
  until (a<=120) and (b<=40)and (a>=0) and (b>=0);
  writeln('Прибыль компании составит ',100-b-0.5*a,'%');
end.

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

оба задания 1) упорядочить одномерный вещественный массив из 20 элементов по убыванию методом перебора. 2) Сформировать вещественную матрицу 5х5. Вычислить произведение отрицательных элементов, находящихся над и под главной диагональю матрицы. Язык С++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

hadzievamareta44
priemni451
zdv686857
ekaterinava90
victoriapetrs
galkar
menametov
ti2107
nkochladze
okison2847
armynis8
kolgatin69
ВалентиновичСуриковна1104
Aнaлитикaлық мaшинaAнaлитикaлық мaшинa
palosik7621
airlineskozlova69