ПолухинаТененева565
?>

С клавиатуры вводится последовательность целых чисел пока не введем число 0. Напишите программу которая вычисляет среднее арифметическое отрицательных чисел и среднее геометрическое положительных чисел

Информатика

Ответы

ShafetdinovAndrei
1. Современное, короткое и быстрое решение

// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(16,-20,80); a.Println;
  Writeln('S=',a.Where((x,i)->i.IsOdd).Sum)
end.

Пример
61 64 70 22 76 22 18 44 36 53 29 -9 42 -19 66 34
S=211

2. А вот так все еще учат в большинстве школ (стиль образца 70-80х годов века)

const
  n=16;
var
  i,s:integer;
  a:array[1..n] of integer;
begin
  Randomize;
  s:=0;
  for i:=1 to n do begin
    a[i]:=Random(101)-20;
    Write(a[i],' ');
    if i mod 2=0 then s:=s+a[i]
    end;
  Writeln;
  Writeln('S=',s)
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С клавиатуры вводится последовательность целых чисел пока не введем число 0. Напишите программу которая вычисляет среднее арифметическое отрицательных чисел и среднее геометрическое положительных чисел
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

espectr-m
aleksandramir90
N-odes-art-school410
siger06297
dariagromova54
bulk91675
sv455umarketing74
lezzzzka5510
Kushchenko-Monashev
AkimovaI1608
Svetlana
Михайлов
Goldaram84
olqa27
Илья_Ветклиники1655