Designer
?>

1) Дано уравнение вида: = ∗++. В данном уравнении Вам необходимо написать программу, которая высчитывает r. Переменные a, b, c записать с оператора ввода. 2) Написать программу, которая сравнивает два числа и выводит сообщение с информацией о том какое число больше, и на сколько больше. 3) Пользователь вводит число. Написать программу, которая оценивает это число: a. Если число четное, и положительное (>0), то вывести «Категория А» b. Если же число четное и отрицательное (<0) – вывести «Категория B» c. Если число нечетное и положительное – «Категория С» d. И если число нечетное и отрицательное – «Категория D» 4) Найти сумму чисел от 1 до 50. Выполнить с цикла for 5) Вывести все четные числа от 1 до 100. Выполнить с цикла while. 6) Заполнить массив 10 числами. Найти среднее арифметическое элементов массива. (Сложить все элементы и разделить на 10

Информатика

Ответы

zakaz6354

В паскале

1) program one;

uses crt;
var a:array [1..10] of integer;
x: real; i:integer;
begin
clrscr;
x:=0;
for i:=1 to 10 do
readln(A[i]);
for i:=1 to 10 do
begin
if (A[i]<0) or (A[i] mod 2=0) then
x:=x+Sqr(A[i]);
end;
writeln;
write(x);
end.

2)

program two;
uses crt;
var a:array [1..52] of integer;
x,i: integer;
begin
clrscr;
x:=34;
for i:=1 to 52 do
begin
A[i]:=1+x;
x:=x+1;
if (A[i] mod 7 =1)or (A[i] mod 7 =2) or (A[i] mod 7 =5)
then writeln(A[i]);
end;
end.

3)

Program three;
Uses crt;
var n,x:integer; a,y:real;
begin
Clrscr;
readln(a,n);
for x:=1 to n do
y:=x*a;
writeln(y);
end.

4)

Program four;
Uses crt;
var A:array [1..100] of integer;
n,i,max,x:integer;
begin
clrscr;
writeln('vvedite kol-vo elementov');
readln(n);
writeln('Vvedite elementy');
for i:=1 to n do
read(A[i]);
for i:=1 to n do
begin
max:=A[1];
if (A[i] <0) and (A[i]>A[x])
then max:=A[i];
x:=i;
end;
writeln ('Naib',max,'nomer',x);
end.

5)

Program abc;
Uses crt;
var S,a,b:integer;
begin
clrscr;
S:=0;
a:=1;
b:=3;
while a<98 do
begin
while b<100 do
begin
S:=S+b-a;
a:=a+4;
b:=b+4;
end;
end;
writeln(s);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1) Дано уравнение вида: = ∗++. В данном уравнении Вам необходимо написать программу, которая высчитывает r. Переменные a, b, c записать с оператора ввода. 2) Написать программу, которая сравнивает два числа и выводит сообщение с информацией о том какое число больше, и на сколько больше. 3) Пользователь вводит число. Написать программу, которая оценивает это число: a. Если число четное, и положительное (>0), то вывести «Категория А» b. Если же число четное и отрицательное (<0) – вывести «Категория B» c. Если число нечетное и положительное – «Категория С» d. И если число нечетное и отрицательное – «Категория D» 4) Найти сумму чисел от 1 до 50. Выполнить с цикла for 5) Вывести все четные числа от 1 до 100. Выполнить с цикла while. 6) Заполнить массив 10 числами. Найти среднее арифметическое элементов массива. (Сложить все элементы и разделить на 10
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

os7960
Sergei_Olga658
kristinmk
annasolod
agaltsova86
pafanasiew
ekaterinkat
ВладимировичСтанислав
ольга1801
Lomakina-Valerievna1779
yusovd291
ogonizoloto
Юлия1689
Vasileva