Kulikovvl9
?>

Написать программу на языке Python, которая позволяет рассчитать завИСИМОСТЬ силы тяжести F от массы тела m иускорения свободного падения g (постоянная 9.8), используяформулу: F=mg. Массу тела запросить у ПОЛЬЗОвателя спояснением. Результат вывести с пояснением. сор​

Информатика

Ответы

serge-lysoff

uses GraphABC;

var

n, i: integer;

a: array of integer = (0,0, 100,270, 85,170, 240,165, 250,65, 410,65, 413,170, 405,270, 100,270, //кузов

0,0, 251,165, 260,75, 328,75, 320,165, 280,225, 245,225, 251,165, 320,165, //дверь

0,0, 330,165, 338,75, 400,75, 403,165, 330,165, //окно

0,0, 170,167, 170,140, 180,137, 180,70, 185,65, 185,137, 195,140, 195,166,//труба

0,0, 168,290, 105,353, 42,290, 105,227, 168,290, 0,0, 163,314, 81,348, 47,266, 129,232, 163,314,

0,0, 150,335, 60,335, 60,245, 150,245, 150,335, 0,0, 129,348, 47,314, 81,232, 163,266, 129,348, //п.колесо

0,0, 463,265, 375,353, 287,265, 375,177, 463,265, 0,0, 456,299, 341,346, 294,231, 409,184, 456,299,

0,0, 437,327, 313,327, 313,203, 437,203, 437,327, 0,0, 409,346, 294,299, 341,184, 456,231, 409,346); //з.колесо

begin

for n := 0 to Length(a) div 2 - 1 do

begin

i := 2*n;

if (a[i] = 0) and (a[i + 1] = 0)

then

MoveTo(a[i + 2], a[i + 3])

else

LineTo(a[i], a[i + 1]);

end;

end.

Проверял в PascalABC.NET 3.4.2

Правда, предварительно ещё рассчитал все точки обоих колёс вот по этой программе (но, это уже так, просто для сведения):

var

x1, y1, r1, x2, y2, r2: integer;

n, i: integer;

a: real;

begin

x1:=105; y1:=290; r1:=63;

x2:=375; y2:=265; r2:=88;

for i := 0 to 3 do

begin

write (0,',',0,', ');

for n := 0 to 4 do

begin

a:=90*(n mod 4)+22.5*i;

write (Round(r1*Cos(Pi*a/180))+x1,',', Round(r1*Sin(Pi*a/180))+y1,', ');

end;

end;

writeln ();

for i := 0 to 3 do

begin

write (0,',',0,', ');

for n := 0 to 4 do

begin

a:=90*(n mod 4)+22.5*i;

write (Round(r2*Cos(Pi*a/180))+x2,',', Round(r2*Sin(Pi*a/180))+y2,', ');

end;

end;

write (');');

end.


Нарисовать трактор в паскале с цикла For! Очень
Нарисовать трактор в паскале с цикла For! Очень

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке Python, которая позволяет рассчитать завИСИМОСТЬ силы тяжести F от массы тела m иускорения свободного падения g (постоянная 9.8), используяформулу: F=mg. Массу тела запросить у ПОЛЬЗОвателя спояснением. Результат вывести с пояснением. сор​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yumashev
macmakka
samsludmila
svetlana-sharapova-762621
edubenskaya
chavagorin
danaya3005
dedald
gub191025
natkuv7
Сорокина
Андреевич-Екатерина1974
leeteukism
byfetvostochniy
alexandergulyamov
▲