proplenkusale88
?>

Написать программу для задачи: "Найти максимальный и минимальный элемент массива из 5 элементов" заранее

Информатика

Ответы

Panfilov_Anna
Program n1;
const n=15;
var a: array[1..n] of integer;
pc,pn,nmin,nmax,max,min,i: integer;
begin
randomize;
pc:=1;
pn:=1;
write('массив: ');
for i:=1 to n do begin
a[i]:=random(100);
write(a[i],' ');
end;
writeln;
for i:=1 to n do if i mod 2=0 then pc:=pc*a[i] else pn:=pn*a[i];
if pc>pn then begin
max:=a[1];
for i:=2 to n do if a[i]>max then begin
max:=a[i];
nmax:=i;
end;
writeln('номер максимального элемента: ',nmax);
end else
begin
min:=a[i];
for i:=2 to n do if a[i]<min then begin
min:=a[i];
nmin:=i;
end;
write('номер минимального элемента: ',nmin);
end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу для задачи: "Найти максимальный и минимальный элемент массива из 5 элементов" заранее
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

misspodvigina
озерская_Мария1234
dkedrin74038
titovass9
yrgenson2011801
Tuzov
Igor120
assistant
fishka-sokol14
pavlova7771960
legezin
anna-ditman
Li-111
dmitryshigin
oooviktoria17
▲