Поделитесь своими знаниями, ответьте на вопрос:
НУЖНА С ПАСКАЛЬ Ребят, подскажите, кто знает: написала 2 проги в паскаль(самостоятельно), но где-то есть недоработка и они работают неправильно. Компилятор никакой ошибки не выводит, поэтому не могу разобраться в чём дело... Прикрепляю задания, свои коды и скрины работы прог: 1)Составить программу на Паскале, которая удалит все буквы «о» из текста, который состоит из 6 слов. Текст нужно придумать самостоятельно. Мой код: program udalenye; var s, s1: string; i: byte; begin writeln('введите текст, состоящий из 6 слов'); readln(s); writeln('исходная строка: ', s); s1:=''; for i:=1 to length(s) do if (s[i]<>'о') then s1:=s1+s[i]; writeln('строка после удаления всех букв "о": ', s1); end. 2)Определить, сколько раз в тексте встречается буква «и». В качестве входных данных введите текст, состоящий из Ваших фамилии, имени и отчества. Мой код: program bukva; var s: string; i, k: integer; len: byte; begin k:=0; writeln('введите имя, фамилию и отчество'); readln(s); len:=length(s); for i:=1 to len do begin if s[i]='и' then k:=k+1; end; writeln('буква "и" встречается в тексте ', k, ' раза(раз)'); end.
var a,b,c:array[10..99] of integer;
ast,bst,cst:string;
i:integer;
begin
ast:='A:';
bst:='Б:';
cst:='В:';
for i:=10 to 99 do
begin
c[i]:=i;
a[i]:=c[i]-i+random(50);
b[i]:=c[i]-a[i];
ast:=ast+' '+inttostr(a[i]);
bst:=bst+' '+inttostr(b[i]);
cst:=cst+' '+inttostr(c[i]);
end;
setpencolor(clRed);
line(0,0,150,0);
line(150,0,75,50);
line(75,50,0,0);
rectangle(0,50,150,300);
DrawTextCentered(0,50,150,300,ast);
setpencolor(clYellow);
line(150,0,300,0);
line(300,0,225,50);
line(225,50,150,0);
rectangle(150,50,300,300);
DrawTextCentered(150,50,300,300,bst);
setpencolor(clGreen);
line(300,0,450,0);
line(450,0,375,50);
line(375,50,300,0);
rectangle(300,50,450,300);
DrawTextCentered(300,50,450,300,cst);
end.