info2
?>

Написать программу, которая: Задайте два вектора А (n) и В (m Выполню Такие задачи:1. определить вектор С так, чтобы все его элементы были Уровни сумме соответствующих элементов векторов А и В, если в А и В разница между любыми двумя соседними элементами НЕ превосходит максимального значения двух векторов; если же превосходит, то D будет вектором Нулевой элементов Количество которых доривнюватиме целой части максимального значения с двух векторов;2. Определить произведение элементов вектора, расположенных между дерет достойной Нулевой элементами;3. Преобразовать вектор так, чтоб сначала располагались все элементы, равные нулю, а потом - все остальные элементы.

Информатика

Ответы

Маргарита595
#define _CRT_SECURE_NO_WARNINGS
#include <stdlib.h>
#include <stdio.h>
#include <locale>

int main()
{
    setlocale(LC_ALL, "RUSSIAN");
    float a;
    int b;
    bool flag=false;
    char str[20];
    printf("Введите число >> ");
    scanf("%f", &a);
    b = a;
    float c = a - b;
    sprintf(str, "%5.3f", c);
    printf("Дробная часть: %s", str);
    for (int i = 2; i < 5; i++)
    {
        if (str[i] == '0')
            flag = true;
    }
    if (flag == true)
        printf("\nПервые три цифры дробной части содержат цифру 0");
    else
        printf("\nПервые три цифры дробной части не содержат цифру 0");
    printf("\n ");
    system("pause");
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая: Задайте два вектора А (n) и В (m Выполню Такие задачи:1. определить вектор С так, чтобы все его элементы были Уровни сумме соответствующих элементов векторов А и В, если в А и В разница между любыми двумя соседними элементами НЕ превосходит максимального значения двух векторов; если же превосходит, то D будет вектором Нулевой элементов Количество которых доривнюватиме целой части максимального значения с двух векторов;2. Определить произведение элементов вектора, расположенных между дерет достойной Нулевой элементами;3. Преобразовать вектор так, чтоб сначала располагались все элементы, равные нулю, а потом - все остальные элементы.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zaha98
Анатольевич-Лариса
ag-modul
gennadevna
Штакина1568
moto-eskort
anton-www1
voen-torg
yaart-klementiev29
alekseydovganich6
Ainura Pokhomova
alexeylipatov
osipovasalex5316
edelstar83