?>
Задача: Простой ориентированный граф задан списком ребер, выведите его представление в виде матрицы смежности. Входные данные На вход программы поступают числа n ( 1≤n≤100 ) – количество вершин в графе и m ( 1≤m≤n(n−1) ) – количество ребер. Затем следует m пар чисел – ребра графа. Выходные данные Выведите матрицу смежности заданного графа. КОД: var a, b, m, n, i, j, k, x, y:longint; mas: array [1..1000, 1..1000] of integer; begin read(n, m); for k:= 1 to m do readln(x, y); a:=n; b:=n; for i:=1 to a do begin for j:=1 to b do begin if (i= y) and (j= x) then if j=b then writeln(1) else write(1) else if j=b then writeln(0) else write(0); end; end; end. ...
Ответы
1. Чтобы решить задачу, надо определить, какое количество варенья съест Машенька за 20 дней. Вначале вычислим это количество в ложках, если известно, что за день она съедает по 5 ложек варенья:
5 * 20 = 100 ложек.
2. Теперь переведем 100 ложек варенья в граммы, если известно, что каждая ложка помещает 5 г варенья:
100 * 5 = 500 грамм.
3. Если исходное количество варенья составляет 650 грамм, тогда вычтем из этой массы ту часть, что съест Машенька за 20 дней и получим массу оставшегося варенья через 20 дней:
650 - 500 = 150 грамм.
ответ: получили, что через 20 дней в банке останется всего 150 грамм варенья.