sharikplushelen
?>

По аналогии с заданием "Умный холодильник" из классной работы разработайте умного робота , который будет запоминать все дела, которые нужно сделать ученику для школы. Программа выводит на экран актуальное положение дел по домашней работе. Напоминает сделать какое-то задание, если оно ещё не сделано. Пример команды: математика -1 значит, что сделано 1 задание по математике, биология +2 значит, что задано ещё два задания по биологии. Пример вывода: Математика: 3 задан. Русский: 1 задан. Биология: 0 задан. Рекомендации: сделать математику. Команда состоит из двух частей: предмет количество заданий (как оно меняется Можете добавить от себя любые функции на ваше усмотерние :) P.S. Эта задача не имеет тестов автопроверки, её будет проверять вручную ваш преподаватель. Формат входных данных Команды пользователя Формат выходных данных Ситуация по заданиям с разных предметов и рекомендации Примечания Чтобы на Питоне считать слово и число в одной строке: product, num = input().split() num = int(num)

Информатика

Ответы

D-posilochka

--- Python 3.8.3 ---

import typing

from typing import Callable

from typing import Any

Primitive = typing.TypeVar('Primitive', int, float, complex, str, bytes, bytearray)

def ReadSeqWhile(predicate: Callable[[Any], bool], SeqType: Primitive = int):

   '''

   Возвращает последовательность элементов в указанном типе, считываемых с клавиатуры, пока ввод удовлетворяет условию

   '''

   temp = SeqType(input())

   while predicate(temp):

       yield temp

       temp = SeqType(input())

def main():

   InputData = ReadSeqWhile(lambda p: p != '', SeqType = str)

   for _ in InputData:

       print('text')

   

if __name__ == "__main__":

   main()

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

По аналогии с заданием "Умный холодильник" из классной работы разработайте умного робота , который будет запоминать все дела, которые нужно сделать ученику для школы. Программа выводит на экран актуальное положение дел по домашней работе. Напоминает сделать какое-то задание, если оно ещё не сделано. Пример команды: математика -1 значит, что сделано 1 задание по математике, биология +2 значит, что задано ещё два задания по биологии. Пример вывода: Математика: 3 задан. Русский: 1 задан. Биология: 0 задан. Рекомендации: сделать математику. Команда состоит из двух частей: предмет количество заданий (как оно меняется Можете добавить от себя любые функции на ваше усмотерние :) P.S. Эта задача не имеет тестов автопроверки, её будет проверять вручную ваш преподаватель. Формат входных данных Команды пользователя Формат выходных данных Ситуация по заданиям с разных предметов и рекомендации Примечания Чтобы на Питоне считать слово и число в одной строке: product, num = input().split() num = int(num)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

remontsalarievo2
Salkinserg
Вишняков997
masha812
xalina85
ooofishai4064
krutikovas
kapitan19
Мусаев Игоревич371
Светлана308
Можарова14
Itina321t
алексей-Ветошкин
Мунировна
oksanakv1950