При запуске программы массив для неё не имеет никакого значения. Он создан только для того чтобы программистам было написать программу.
Пример(он будет на языке С++ но суть думаю будет понятна)
Создадим 5 переменных
int a1 = 1;
int a2 = 2;
int a3 = 3;
int a4 = 4;
int a5 = 5;
И вот для того чтобы вывести нам нужно будет написать
cout << a1 << a2 << a3 << a4 << a5;
Это не удобно по этому программисты придумали массивы.
Создадим массив для 5 элементов
int a[4]; // Так как отчёт начинает с нуля. 0,1,2,3,4
и заполним, а так же выведем его при цикла
for(int i = 1; i<=4; i++){
a[i] = i;
cout << a[i];
}
Код стал намного меньше и намного лучше читабельный.
Поделитесь своими знаниями, ответьте на вопрос:
15. Calculate the number of lowercase (small) and uppercase (large) letters in the entered string. Only use English letters. 19. Write a Python program to calculate the length of a string Хелп ми
При запуске программы массив для неё не имеет никакого значения. Он создан только для того чтобы программистам было написать программу.
Пример(он будет на языке С++ но суть думаю будет понятна)
Создадим 5 переменных
int a1 = 1;
int a2 = 2;
int a3 = 3;
int a4 = 4;
int a5 = 5;
И вот для того чтобы вывести нам нужно будет написать
cout << a1 << a2 << a3 << a4 << a5;
Это не удобно по этому программисты придумали массивы.
Создадим массив для 5 элементов
int a[4]; // Так как отчёт начинает с нуля. 0,1,2,3,4
и заполним, а так же выведем его при цикла
for(int i = 1; i<=4; i++){
a[i] = i;
cout << a[i];
}
Код стал намного меньше и намного лучше читабельный.