len22
?>

. ЭТО УЖЕ КРИК ДУШИ!! Напишите программу по-братски я сижу над ней ооочень долго, но ничего на ум не приходит

Информатика

Ответы

Артем Уберт
Const n=10; 
var a:array[1..n] of integer;
i,s,min:integer;
begin
writeln('Исходный массив:');
for i:=1 to n do
 begin
 a[i]:=random(21)-10;
 write(a[i]:4);
 end;
writeln;
s:=0; 
min:=a[1];
for i:=1 to n do
 begin
 if a[i]>0 then s:=s+a[i];
 if a[i]<min then min:=a[i];
 end;
writeln('s = ',s,'   min = ',min);
for i:=1 to n do
 if a[i]>0 then a[i]:=s
  else if a[i]<0 then a[i]:=a[i]-min;
writeln('Измененный массив:');
for i:=1 to n do  write(a[i]:4);
writeln;
end.

Пример:
Исходный массив:
   9  -3  -5   7   1   5  -6   9  -8   7
s = 38   min = -8
Измененный массив:
  38   5   3  38  38  38   2  38   0  38

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

. ЭТО УЖЕ КРИК ДУШИ!! Напишите программу по-братски я сижу над ней ооочень долго, но ничего на ум не приходит
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

goldservicepro
Константин Андрей
ustinovalubov6666
mariyachervonnaya44
borisova-Sergeevna
turoverova5
tumanowivan2015509
platonm777639
v79150101401
Анатольевич1707
maslprod
lavr74
tyrnaus
luza5
Алексей424