Nikolaevich824
?>

РЕШИТЕ С ОБЪЯСНЕНИЕМ в ИТ-компании работают 90 сотрудников. 55 сотрудников знают Java, 54 сотрудника - Python, 36 сотрудников - C++. Известно, что 51 сотрудник знает Python и Java одновременно, 11 сотрудников в компании совсем не владеют никаким языком программирования и никто не знает Java и C++ одновременно. Определите, сколько сотрудников знает одновременно Python и C++? ПРАВИЛЬНЫЙ ОТВЕТ : 15.

Информатика

Ответы

alex6543213090
1)
var a: array [1..10] of integer;
    i, m: integer;
begin
     for i := 1 to 10 do
     begin
          a[i] := random(20);
          writeln('[', i, '] => ', a[i]);
          if (a[i] mod 2 = 0) then m := m + a[i];
     end;
     writeln(m);
end.

2)
var a: array [1..10] of integer;
    i, m: integer;
begin
     m := 1;
     for i := 1 to 10 do
     begin
          a[i] := random(20);
          writeln('[', i, '] => ', a[i]);
          if (a[i] mod 2 = 1) then m := m * a[i];
     end;
     writeln(m);
end.

3)
var a: array [1..10] of integer;
    i, m: integer;
begin
     m := 1;
     for i := 1 to 10 do
     begin
          a[i] := random(20);
          writeln('[', i, '] => ', a[i]);
          m := m + a[i];
     end;
     writeln(m / 10);
end.

4)
var a: array [1..10] of integer;
    i, m, c: integer;
begin
     m := 1;
     for i := 1 to 10 do
     begin
          a[i] := random(20);
          writeln('[', i, '] => ', a[i]);
          if (a[i] mod 2 = 0) then
          begin
               m := m + a[i];
               c := c + 1;
          end;
     end;
     if (c > 0) then writeln(m / c);
end.

Вас =)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

РЕШИТЕ С ОБЪЯСНЕНИЕМ в ИТ-компании работают 90 сотрудников. 55 сотрудников знают Java, 54 сотрудника - Python, 36 сотрудников - C++. Известно, что 51 сотрудник знает Python и Java одновременно, 11 сотрудников в компании совсем не владеют никаким языком программирования и никто не знает Java и C++ одновременно. Определите, сколько сотрудников знает одновременно Python и C++? ПРАВИЛЬНЫЙ ОТВЕТ : 15.
Ваше имя (никнейм)*
Email*
Комментарий*