siyaniemoskva
?>

ТОЛЬКО НА PYTHON, ДЕЛАТЬ ПО ПРЕЗЕНТАЦИИ Напишите программу, которая сортирует массив и находит количество различных чисел в нем. Пример: Массив: 5 3 4 2 1 6 3 2 4 После сортировки: 1 2 2 3 3 4 4 5 6 Различных чисел: 6

Информатика

Ответы

ocik1632933

C++ GNU. Простое заполнение массива, а потом в цикле проверки.

В конце выводим результаты.

Мой вариант решения:

#include <iostream>

using namespace std;

int main()

{

const int size = 20;

int arr[size];

for (int i = 0; i < size; ++i)

{

 cout << "Enter " << i << " element -> ";

 cin >> arr[i];

}

int AllSum = 0;

int EvSum = 0;

int OddSum = 0;

int EvCounter = 0;

int OddCounter = 0;

int SmallThenZero = 0;

for (int i = 0; i < size; ++i)

{

 AllSum += arr[i];

 if (arr[i] < 0) SmallThenZero++;

 if (arr[i] % 2 == 0)

 {

  EvCounter++;

  EvSum += arr[i];

 }

 else

 {

  OddCounter++;

  OddSum += arr[i];

 }

}

cout << "Even numbers counter - " << EvCounter << endl;

cout << "Odd numbers counter - " << OddCounter << endl;

cout << "Even numbers sum - " << EvSum << endl;

cout << "Odd numbers sum - " << OddSum << endl;

cout << "All numbers sum - " << AllSum << endl;

cout << "Small then zero numbers - " << SmallThenZero << endl;

cin.get();

cin.get();

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ТОЛЬКО НА PYTHON, ДЕЛАТЬ ПО ПРЕЗЕНТАЦИИ Напишите программу, которая сортирует массив и находит количество различных чисел в нем. Пример: Массив: 5 3 4 2 1 6 3 2 4 После сортировки: 1 2 2 3 3 4 4 5 6 Различных чисел: 6
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Pona4ka93
k-serga1
unalone5593
Katkova
dp199088206
djikia88
Aleksandrovich-Yurevna1421
juliajd
Максим
anitanemtsewa
Guru-tailor
tigo1
михаил
СмыковаДарья1969
mariy-y34
▲