Викторовна
?>

Задание No3 У исполнителя Удвоитель две команды:1. прибавь 12. умножь на 2Напишите программу из 4 команд, которая преобразует число б в число 30.1)ответ:Задание №4У исполнителя Удвоитель две команды:1. прибавь 12. умножь на 2Напишите программу из 5 команд, которая преобразует число 3 в число 19.1)ответ:Задание №5У исполнителя Калькулятор две команды:1. Вычти 32. умножь на 2Напишите программу из 4 команд, которая преобразует число 7 в число 13.1)ответ:​

Информатика

Ответы

dmitriy
Var x,y,z,Ans:integer;
    u:real;
Begin
  Write('Введите числа x,y,z: ');
  Readln(x,y,z);
  Writeln('Что вычислить из числа ',x,' ?');
  Writeln('1 - sin; 2 - cos; 3 - tg;');
  Readln(Ans);
    case Ans of
    1: begin u:=sin(x); Writeln('sin(',x,') = ',u) end;
    2: begin u:=cos(x); Writeln('cos(',x,') = ',u) end;
    3: begin u:=tan(x);  Writeln('tg(',x,') = ',u) end;
    else Writeln('Ошибка!')    end;
  Writeln('Найти максимальное число из ряда ',u,', ',y,', ',z);
  Writeln('Без модуля - 1; по модулю - 2');
  Readln(Ans);
    case Ans of
     1: begin
         if (u>y) and (u>z) then
 Writeln('Максимальное число - ',u)
          else
                if (y>u) and (y>z) then Writeln('Максимальное число - ',y)
                  else
                      if (z>u) and (z>y) then Writeln('Максимальное число - ',z)
                        else
                            Writeln('Все числа равны.')
        end;
    2: begin
         if (abs(u)>abs(y)) and (abs(u)>abs(z)) then
 Writeln('Максимальное число - ',u)
          else
                if (abs(y)>abs(u)) and (abs(y)>abs(z)) then 
Writeln('Максимальное число - ',y)
                  else
                      if (abs(z)>abs(u)) and (abs(z)>abs(y)) then
 Writeln('Максимальное число - ',z)
                        else Writeln('Все числа равны.')
        end
    end
End.

*.pas прикрепил во вложения

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задание No3 У исполнителя Удвоитель две команды:1. прибавь 12. умножь на 2Напишите программу из 4 команд, которая преобразует число б в число 30.1)ответ:Задание №4У исполнителя Удвоитель две команды:1. прибавь 12. умножь на 2Напишите программу из 5 команд, которая преобразует число 3 в число 19.1)ответ:Задание №5У исполнителя Калькулятор две команды:1. Вычти 32. умножь на 2Напишите программу из 4 команд, которая преобразует число 7 в число 13.1)ответ:​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tanyaandreeva728
academycoffee243
olimp201325
Yumashev
elenaperemena8
parolmm
d2002
ikhilovb76
grazia2017
myxa120283
elenaneretina
Melnik Kaveshnikova1746
avto3132
nataliarogacheva
Dmitrii_Shamilevich2019