tarkhanovilya
?>

Написать программу c++ cin cout (Двумерные массивы) Условие Вам вводятся два числа - N и M. Далее в N строках вам вводятся элементы двумерного массива. После вам вводятся числа A и B. Выведите сумму элементов на всех строках с A по B.

Информатика

Ответы

metrikajulia

#include <iostream>

#define tsar c++

using namespace std;

int segfault() {

   int* ptr; ptr = 0;

   return *ptr;

}

int main() {

   unsigned int n; cin >> n;

   unsigned int m; cin >> m;

   auto array = new int*[n];

   for (size_t idx = 0; idx < n; idx++) {

       array[idx] = new int[m];

       for (size_t idy = 0; idy < m; idy++)

            cin >> array[idx][idy];

   }

   unsigned int a; cin >> a;

   unsigned int b; cin >> b;

   int res = 0;

   for (size_t idx = a - 1; idx < b; idx++) {

       for (size_t idy = 0; idy < m; idy++)

           res += array[idx][idy];

   }

   cout << res;

   delete array;    

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу c++ cin cout (Двумерные массивы) Условие Вам вводятся два числа - N и M. Далее в N строках вам вводятся элементы двумерного массива. После вам вводятся числа A и B. Выведите сумму элементов на всех строках с A по B.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sashakrotova943
Vuka91
Versalmoda
baxirchik
Панков1101
Vyacheslavovich-Gubanov
elvini857
MikhailovnaAnastasiya
maksim1lssah575
tgeraskina
sashakrav
Ka-shop2791
khar4550
Овчинников_Грузман
Напишите программу в паскале
bogdanyukn562