olma-nn477
?>

написать программу на С# Дано предложение, оканчивающееся точкой. Из символов предложения построить линейный однонаправленный список.

Информатика

Ответы

vs617

1.

var arr: array[1..6] of integer;

var i, summ: integer;

begin

 summ:= 0;

 for i:=1 to 6 do

 begin

   readln(arr[i]);

 end;

   

 for i:=1 to 6 do

   begin

       if arr[i]>4 then

           summ := summ+arr[i];

   end;

   

 writeln(summ);

end.

var arr: array[1..7] of integer;

var i, mult: integer;

begin

 mult:= 1;

 for i:=1 to 7 do

 begin

   readln(arr[i]);

 end;

   

 for i:=1 to 7 do

   begin

       if arr[i]>0 then

           mult := mult*arr[i];

   end;

   

 writeln(mult);

end.

Краткий гайд

i - переменная-счётчикarr - массив, с которым производятся операцииsumm - (в первом задании - переменная, отвечает за сумму элементовmult - (во второй части) отвечает за произведение

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу на С# Дано предложение, оканчивающееся точкой. Из символов предложения построить линейный однонаправленный список.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

karien87
спец387
MN-Natusik80
Алла14
stalker2201
Aleksandr362
Пономаренко
Антон
Лифанов_Ольга
randat887040
Шапкина1531
vadimnechaev23150
gamolml
barnkim
krisrespect2
▲