test43
?>

Нужно:1 написать программу которая посчитает сумму положительных (отдельно) и отрицательных (отдельно) чисел (n брать от 30 до -13 с шагом 1)2 Написать программу, которая посчитает разность положительных чисел (отдельно) и произведение отрицательных чисел (n берем от 37 до -6 с шагом -1)​

Информатика

Ответы

Владимировна Екатерина

{pascalabc}

program f0rwardirop;

var  

  r,x,y: real;

  b: boolean;

  i: integer;

  s: string;

begin

  s: =' -=alphaeus=- ';

  for i: =1 to 22 do begin write(s[i]); sleep(200) end;

  writeln; write('ok, введите r = '); readln(r);

  write('теперь введите х = '); readln(x);

  write('и, наконец, введите y = '); readln(y);

  if x> =0 then

    if (x*x+y*y < = r*r) then b: = true else b: =false

    else

      if (abs(x) < =r) and (abs(y) < =r) and (abs(x) < = abs(y)) then b: = true else b: =false;

  if b then writeln('точка (',x,',',y,') принадлежит закрашенной области')

  else writeln('точка (',x,',',y,') не принадлежит закрашенной области');

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно:1 написать программу которая посчитает сумму положительных (отдельно) и отрицательных (отдельно) чисел (n брать от 30 до -13 с шагом 1)2 Написать программу, которая посчитает разность положительных чисел (отдельно) и произведение отрицательных чисел (n берем от 37 до -6 с шагом -1)​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

utkinslava
mihailpolehin8
Vasilevich Fokin
ivanrancev
kosbart28
rosik76
natakrechko
timeev3160
Natalimis416024
Azat859
sastakhova
buff-studio
Шарабанов
zhmulyov-denis8
Fedorovich_Aleksandrovich685