Borisovna24
?>

Написать программу, которая считывает текст из файла и определяет сколько в нем слов, состоящих из не более 4 букв.c++

Информатика

Ответы

tolyan791

ответ: попробуй  

объяснение:

void __fastcall tform1: : button1click(tobject *sender)

{

  int count = 0;

  tstringlist *list = new tstringlist; // г±г®г§г¤г*гґг¬ г±гїгёг±г®гє

  list-> loadfromfile("f: \\гљгіг«гјгігёг*\\info.txt");

  memo1-> text =   list-> text;

  list-> delimitedtext = memo1-> text;

  memo2-> text = list-> delimitedtext;

  for (int i=0; i < list-> count; i++)

  {

    if ( list-> strings[i].length() < = 4 )

    {

      count++;

    }

  }

  label1-> caption = inttostr(count);

  delete list;

  list = null;

}

vlrkinn
Const   mm=50; { максимально возможное кол-во строк }   nn=50; { максимально возможное кол-во столбцов } var   f: array[1..mm,1..nn] of integer;   i,j,m,n,k,s: integer; begin   randomize;   write('количество строк в массиве: '); read(m);   write('количество столбцов в массиве: '); read(n);   writeln('*** исходный массив ***');   for i: =1 to m do begin       for j: =1 to n do begin           f[i,j]: =random(41)-20; { [-20; 20] }           write(f[i,j]: 4)           end;       writeln       end;   write('количество положительных элементов, кратных 7: ');   k: =0;   for i: =1 to m do       for j: =1 to n do           if (f[i,j]> 0) and (f[i,j] mod 7=0) then k: =k+1;   writeln(k);   write('среднее арифметическое отрицательных элементов: ');   k: =0; s: =0;   for i: =1 to m do       for j: =1 to n do           if f[i,j]< 0 then begin k: =k+1; s: =s+f[i,j] end;   if k> 0 then writeln(s/k: 0: 5)   else writeln(0);   write('минимальный элемент равен ');   k: =100;   for i: =1 to m do       for j: =1 to n do           if f[i,j]< k then k: =f[i,j];   write(k,', индексы: ');   for i: =1 to m do       for j: =1 to n do           if f[i,j]=k then write(' [',i,',',j,']');   writeln;   write('максимальный элемент среди отрицательных равен ');   k: =-100;   for i: =1 to m do       for j: =1 to n do           if (f[i,j]> k) and (f[i,j]< 0) then k: =f[i,j];   write(k,', индексы: ');   for i: =1 to m do       for j: =1 to n do           if f[i,j]=k then write(' [',i,',',j,']');   writeln; end. пример количество строк в массиве: 5 количество столбцов в массиве: 8 *** исходный массив ***   -4  11  -5 -12    7  16 -10    6     8  -3 -12 -16  15    2  -2  -6   16    8  18    0 -10    8  18    7   17    7 -14  -4  -1  -8  13  -1     3 -18  16 -10    4 -17  19 -18 количество положительных элементов, кратных 7: 3 среднее арифметическое отрицательных элементов: -9.00000 минимальный элемент равен -18, индексы: [5,2] [5,8] максимальный элемент среди отрицательных равен -1, индексы: [4,5] [4,8]
Vik1744184
//pascalabc.net//версия 3.3, сборка 1611 (06.01.2018)begin  var a: =matrrandom(4,5,-20,20).println;   var c: =a.elementsbyrow;   println('кол-во положительных -> ',c.where(t-> t> 0).count);   println('кол-во кратных 7 -> ',c.where(t-> t mod 7=0).count);   println('сред. арифм. отрицат. -> ',c.where(t-> t< 0).average);   var b: =a.elementswithindexes.minby(t-> t[0]);   writeln('минимальный -> ', b[0],'[',b[1]+1,',',b[2]+1,']');   b: =a.elementswithindexes.where(t-> t[0]< 0).maxby(t-> t[0]);   writeln('максимальный отриц. -> ', b[0],'[',b[1]+1,',',b[2]+1,']'); end.пример:   -10    6  12    7    4  -8  -4    3  -1    6    9  -2  16  19 -18  18    4  -3  12  -8кол-во положительных -> 12  кол-во кратных 7 -> 1  сред. арифм. отрицат. -> -6.75  минимальный -> -18[3,5]максимальный отриц. -> -1[2,4]

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая считывает текст из файла и определяет сколько в нем слов, состоящих из не более 4 букв.c++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bristolhouse20151001
vainshakov
Дмитриевич_Скрябин931
Воронина
MikhailNechaeva
АлександровнаАслан1571
elena-vlad822828
npprang21
lubavarif83
nikv568734
Demina-Khokhlov584
osandulyak
Маргарита595
tinadarsi
avguchenkov