ashkiperova6
?>

Написать прогу на паскале.. здоровый щенок играет не менее 8 часов в день. напишите программу которая определяет здоров ли щенок по кличке пуджик

Информатика

Ответы

Tane4ka2110

uses crt;

var x: integer;

begin

writeln('введи сколько времени сегодня играл пудж'); readln(x);

if x> 8 then writeln('пудж здоров')

else writeln('болен');

end.

 

это ветвящийся алгоритм,если больше 8 значит здоров,обратное значение- болен.

AnastasiyaSkripin1283

Программист - это очень интересная и занимательная профессия, используемая практически в любой отрасли, а также и в сельском хозяйстве.  Хороший программист обязан быть предельно внимательным и вдумчивым, склонным к анализу и скрупулезному труду. Он должен быть человеком практичного характера. Программист должен сочетать в себе как гуманитарный, так и технический склад ума. При всём при этом, эти люди должны обладать фантазией и творческим мышлением.

В век компьютерных технологий – это актуальная профессия для нашего времени. Так как роботизация охватывает всё новые и новые сферы жизнедеятельности, я хочу принимать активное участие в их создании.

Также, профессия программиста становится одной из самых востребованных и высокооплачиваемых специальностей в мире. Несложно понять принцип работы машины, ведь все они функционируют на основе одних и тех же алгоритмов. Изучив компьютерную науку, можно стать создателем «нового мира».  Мир, который привлечет миллионы и миллионы пользователей.  

Я считаю, что в работе самое главное квалификация и умения, потому что опыт приходит с годами, а знания необходимы с первых дней работы по специальности. Каждый человек должен заниматься одним делом всю свою жизнь, чтобы стать настоящим профессионалом и быть полезным своей стране и своему народу.  

От выбора профессии зависит будущее человека. Я надеюсь, что сделал правильный выбор. Ведь это - моя жизнь, мой выбор, мой мир, в котором мне предстоит жить.

надеюсь
saryba

звук представляет собой волновые колебания давления в той или иной среде. каковы бы ни были характеристики колебаний, в данном случае важно то, что звук представляет собой нечто неделимое на части (непрерывное), пробегающее в пространстве и времени. чтобы записать звук на какой-нибудь носитель можно соотнести его уровень (силу) с какой-нибудь измеряемой характеристикой этого носителя. так, например, степень намагниченности магнитной ленты в различных ее местах зависит от особенностей звука, который на нее записывался. намагниченность может непрерывно изменяться на протяжении ленты, подобно тому, как параметры звука могут меняться в воздухе. т.е. магнитная лента прекрасно справляется с хранения звука. и хранит его в так называемойаналоговой форме, когда значения изменяются непрерывно (плавно), что близко к естественному звуку.

но как хранить звук на компьютере. здесь любая информация представлена вцифровой форме. данные должны быть представлены числами, а, следовательно, информация в компьютере дискретна (разделена). для того, чтобы записать звук на цифровой носитель информации (например, жесткий диск), его подвергают так называемой оцифровке, механизм которой заключается в измерении параметров звука через определенные промежутки времени ( малые).

дискретизация и квантование

при преобразовании звуковой информации в цифровую форму ее подвергаютдискретизации  и  квантованию. дискретизация заключается в замерах величины аналогового сигнала огромное множество раз в секунду. полученной величине аналогового сигнала сопоставляется определенное значение из заранее выделенного диапазона: 256 (8 бит) или 65536 (16 бит). привидение в соответствие уровня сигнала определенной величине диапазона и есть квантование.

понятно, что как бы часто мы не проводили измерения, все равно часть информации будет теряться. однако и понятно, что чем чаще мы проводим замеры, тем точнее будет соответствовать цифровой звук своему аналоговому оригиналу.

также, чем больше бит отведено под кодирование уровня сигнала (квантование), тем точнее соответствие.

с другой стороны, звук хорошего качества будет содержать больше данных и, следовательно, больше занимать места на цифровом носителе информации.

в качестве примера можно такие расчеты. для записи качественной музыки аналоговый звуковой сигнал измеряют более 44 000 раз в секунду и квантуют 2 байтами (16 бит дает диапазон из 65536 значений). т.е. за одну секунду записывается 88 000 байт информации. это равно (88 000 / 1024) примерно 86 кбайт. минута обойдется уже в 5168 кбайт (86*60), что немного больше 5 мб.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать прогу на паскале.. здоровый щенок играет не менее 8 часов в день. напишите программу которая определяет здоров ли щенок по кличке пуджик
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

osandulyak
Galkin Vladimirovich729
Белов_Лукина1339
mmctriitsk
karpov68
roma8
nastyakrokhina87
Olga-Lev1160
elenaowchinik4842
Dmitrievich1871
gelena03
mmctriitsk
rusart3
Александр Елена1290
Артур1807