ohussyev
?>

Составьте программу, которая находит произведение 10 случайных чисел, лежащих от 1 до 20

Информатика

Ответы

aleksey7800

¿

irkm8

program spos;

uses crt;

var

numb: array [1..100] of byte; // для последовательности чисел

i,f: integer; //счетчик и переменная в качестве флага

begin

randomize;

f: =0;

for i: =1 to 100 do numb[i]: =random(101); // задает последовательность

for i: =1 to 100 do

begin

write(',',numb[i]); // вывод на экран последовательность(можно удалить)

if (numb[i]=77)then f: =1; // в случае удачной проверки f: =1, в противном останется 0

end;

if f=0 then writeln('yes') else writeln('no');

end.

program spos;

uses crt;

var

numb: array [1..100] of byte; // для последовательности чисел

i,f: integer; //счетчик и переменная в качестве флага

begin

randomize;

f: =0;

for i: =1 to 100 do begin

numb[i]: =random(101); // задает последовательность

write(' ',numb[i]); //вывод на экран, можно удалить

end;

writeln;

i: =0;

repeat

i: =i+1;

if (numb[i]=77)then f: =1; // в случае удачной проверки f: =1, в противном останется 0

until i< 100;

if f=0 then writeln('yes') else writeln('no');

end.

stendpost

объяснение:

основные объекты табличного процессора excel:

· ячейка – минимальный объект табличного процессора;

· строка– горизонтальный набор ячеек, заголовки столбцов – a, b, c,…,iv;

· столбец– вертикальны набор ячеек, заголовки строк – 1, 2, 3,…65536;

· адрес ячейки – определяется пересечением столбца и строки (a1, f123, ac72);

· указатель ячейки – рамка;

· активная ячейка– выделенная рамкой, с ней можно производить какие-либо операции;

· смежные ячейки– ячейки расположенные последовательно;

· диапазон (блок) ячеек– выделенные смежные ячейки, образующие прямоугольный участок таблицы;

· адрес диапазона (блока) ячеек - определяется адресом верхней левой и нижней правой ячейки, разделенных двоеточием (: ), b2: c7 → b2, b3, b4, b5, b6, b7, c2, c3, c4, c5, c6, c7.

· книга – документ электронной таблицы, состоящий из листов, объединенных одним именем и являющихся файлом;

· лист– рабочее поле, состоящее из ячеек.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая находит произведение 10 случайных чисел, лежащих от 1 до 20
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alexandergulyamov
Галина-Юлия1292
Elen-ti81459
Shtorm-Shoe
борисовна Елена78
Ионов202
cheshirsky-kot
snopovajulia
egamedicalbuh
alenchik19938823
margarita25061961
Pervosha
expozition
zrv85
yanva