Коробкова1437
?>

C# написать программу, которая запрашивает у пользователя число в диапазоне от 1 до 10. затем компьютер генерирует числа в этом же диапазоне и выводит их на экран до тех пор, пока не угадает заданное пользователем число или не будет нажата клавиша enter

Информатика

Ответы

Timurr007

я никак не понимаю этот вопрос,вообще никак

TSKaraulova
Монитор  – устройство визуального отображения текстовой и графической информации, преобразует цифровую и (или) аналоговую информацию в видеоизображение. стандартный тип мониторов – это мониторы на основе  электронно-лучевой трубки  (элт). такой монитор по принципу работы ничем не отличается от обычного телевизора: пучок лучей, выбрасываемый электронной пушкой, падает на поверхность кинескопа, покрытую особым веществом – люминофором. под действием этих каждая точка экрана светится одним из трёх цветов – красным, зелёным и синим. технология эта старая. обкатанная в течении многих десятилетий, а потому элт– мониторы сегодня – совершенные и недорогие устройства. на их стороне – отличная яркость и контрастность изображения, низкая цена, а следовательно, и доступность.но есть и минусы – вес и габариты элт-монитора ну никак не вписываются в сегодняшние представления о компьютере как о миниатюрном устройстве. прибавьте сюда колоссальное энергопотребление, а также вредное воздействие излучения на пользователя. принтеры   предназначены для вывода на бумагу (создания “твердой копии”) числовой, текстовой и графической информации. по своему принципу действия принтеры делятся на матричные, струйные и лазерные.матричные принтеры  – это принтеры ударного действия. печатающая головка матричного принтера состоит из вертикального столбца маленьких стержней (обычно 9 или 24), которые под воздействием магнитного поля “выталкиваются” из головки и ударяют по бумаге (через красящую ленту). перемещаясь, печатающая головка оставляет на бумаге строку символов.  недостатки   матричных принтеров состоят в том, что они печатают медленно, производят много шума и качество печати оставляет желать лучшего (соответствует примерно качеству пишущей машинки).cтруйные принтеры.   в последние годы широкое распространение получили черно-белые и цветные струйные принтеры. в них используется чернильная печатающая головка, которая под давлением выбрасывает чернила из ряда мельчайших отверстий на бумагу. перемещаясь вдоль бумаги, печатающая головка оставляет строку символов или полоску изображения. струйные принтеры могут печатать достаточно быстро (до нескольких страниц в минуту) и производят мало шума. качество печати (в том числе и цветной) определяется разрешающей способностью струйных принтеров, которая может достигать фотографического качества 2400 dpi. это означает, что полоска изображения по горизонтали длиной в 1 дюйм формируется из 2400 точек (чернильных капель).лазерные принтеры   обеспечивают практически бесшумную печать. высокую скорость печати (до 30 страниц в минуту) лазерные принтеры достигают за счет постраничной печати, при которой страница печатается сразу целиком. высокое типографское качество печати лазерных принтеров обеспечивается за счет высокой разрешающей способности, которая может достигать 1200 dpi и более.сканер   – устройство, которое анализируя какой-либо объект (обычно изображение, текст), создаёт цифровую копию изображения объекта.ручные сканеры   – обычные или самодвижущиеся – обрабатывают полосы документа шириной около 10 см и представляют интерес, прежде всего для владельцев мобильных пк. они медлительны, имеют низкие оптические разрешения (обычно 100 точек на дюйм) и часто сканируют изображения с перекосом. но зато они недороги и компактны.планшетные сканеры  более распространены на рынке, чем другие типы сканеров и имеют ряд преимуществ по объему применения, то есть более универсальны. они напоминают верхнюю часть копировального аппарата: оригинал – либо бумажный документ, либо плоский предмет – кладут на специальное стекло, под которым перемещается каретка с оптикой и аналого-цифровым преобразователем (однако существуют “планшетники”, в которых перемещается стекло с оригиналом, а оптика и апц остаются неподвижными, чем достигается более высокое качество ск анирования).мышь   – устройство манипуляторного типа. перемещение мыши по плоской поверхности синхронизировано с перемещением графического объекта (указателя мыши) на экране монитора. компьютером перемещением мыши по плоскости и кратковременными нажатиями правой и левой кнопок (эти нажатия называются щелчками.)механические мышки. в механических мышах информация о перемещении курсора формируется с резинового шарика, который касается поверхности стола и вращает два координатных валика – горизонтальный и вертикальный. радио-мышки.  в настоящее время появились более современные – беспроводные радио-мышки, которые соединяются с системным блоком с радио-датчика (ресивера), подключенного к компьютерному порту.
bieku68
Program 1; var n,k2,k5,i,a: integer; begin write('n='); read(n); k2: =0; k5: =0; for i: =2 to n do  begin  a: =i;     if a mod 2=0 then  while a> =2 do      begin      a: =a div 2;       k2: =k2+1;     end;   a: =i;   if a mod 5=0 then  while a> =5 do    begin    a: =a div 5;       k5: =k5+1;     end;   end; if k2< k5 then write(k2)  else   write(k5);   readln end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

C# написать программу, которая запрашивает у пользователя число в диапазоне от 1 до 10. затем компьютер генерирует числа в этом же диапазоне и выводит их на экран до тех пор, пока не угадает заданное пользователем число или не будет нажата клавиша enter
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nailya-abdulova25
Linichuk
mshelen732
bas7572513
vsnimschikov391
barekyan096140
ekb676
mali2681208
whitewhit90
zatoichi69
suhanowaswetlana
Tomilova1686
titov-es3095
КараханянКусков
anastasiavilina