Дмитриевич_Скрябин931
?>

Информатика на 6.051. провести трассировку и ответить на вопрос: какую решают с этой программы? var x, y, c: real; begin read (x, y); if x> y then begin c: =x; x: =y; y: =c end; writeln (x, y); end.2. напишите программу, которая вводит с клавиатуры число – значение переменной ч и вычисляет значение у по формуле 5*х + 2, если х> 0у= x/5, если х< =03. напишите программу «подлиза». с клавиатуры вводится символ (m/d) в ответ на вопрос «кто ты? ». программа должна ответить «люблю играть с мальчиками /девочками» в зависимости от ответа на предыдущий вопрос.

Информатика

Ответы

cetarbkilork82
Var     n, l, r, m, k: integer; begin     read(n);     l : = 1;     r : = n;     while (r - l > 1) do     begin         m : = (l + r) div 2;         writeln(m);         read(k);         if (k = 0) then             halt(0)         else if (k = 1) then             l : = m         else             r : = m;     end;     writeln(l);     read(k);     if (k < > 0) then         writeln(r); end.
milaudina
Program zadacha; uses crt; var a, i: integer; z: real; h: array [1..5] of integer; begin clrscr; write  ('vvedite chislo a: '); readln (a); for i: =1 to 5 do begin write ('vvedite elemeny massiva h: '); readln (h[i]); z: =sqrt(h[i]/a); writeln ('h[i]=',h[i], ' z=', z: 0: 4); end; readkey; end. или  program zadacha; uses crt; var a, i: integer; z: real; h: array [1..5] of integer; begin clrscr; write  ('vvedite chislo a: '); readln (a); for i: =1 to 5 do begin write ('vvedite elemeny massiva h: '); readln (h[i]); end; for i: =1 to 5 do begin z: =sqrt(h[i]/a); writeln ('h[', i, ']=',h[i], ' z=', z: 0: 4); end; readkey; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Информатика на 6.051. провести трассировку и ответить на вопрос: какую решают с этой программы? var x, y, c: real; begin read (x, y); if x> y then begin c: =x; x: =y; y: =c end; writeln (x, y); end.2. напишите программу, которая вводит с клавиатуры число – значение переменной ч и вычисляет значение у по формуле 5*х + 2, если х> 0у= x/5, если х< =03. напишите программу «подлиза». с клавиатуры вводится символ (m/d) в ответ на вопрос «кто ты? ». программа должна ответить «люблю играть с мальчиками /девочками» в зависимости от ответа на предыдущий вопрос.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

buyamel
svetasvetlana429
solonataly5
anastasiavilina
sbelova
YaroslavSerganYS5
bondarev05071962
meu72
sedalex
Андреевич-Екатерина1974
Зачем нужны компьютеры и чем они полезны?
mnn99
Мечиславович_Кварацхелия1988
Coffee3862
Сухроб944
nane2924329