Const
n = 12;
var
i, p: integer;
a: array[1..n] of integer;
begin
p := 1;
for i := 1 to n do
begin
a[i] := random(150) - 100;
write(a[i], ' ');
if a[i] > 0 then p := p * a[i];
end;
writeln;
writeln('P = ', p);
end.
2)uses crt;
var a:array [1..10] of integer;
i:integer;
begin
clrscr;
randomize;
{генерируем и выводим новый массив}
for i:=1 to 10 do
begin
a[i]:=random(9)+1;
write(a[i]:3);
end;
writeln;
{в цикле проверяем если счетчик i делится на 2 ( признак четности) то либо возводим в степень либо удваиваем}
for i:=1 to 10 do
begin
if (i mod 2=0 ) then a[i]:=a[i]*a[i]
else a[i]:=a[i]*2;
end;
{выводим конечный массив}
for i:=1 to 10 do
write(a[i]:3);
readkey;
end.
3)var arr:array[1..20] of integer;
max,q:integer;
begin
writeln ('ARRAY: ');
for q:=1 to 20 do
begin
arr[q]:=random(80);
write (arr[q]:3);
end;
max:=arr[1];
for q:=2 to 20 do
if arr[q]>max then max:=arr[q];
writeln;
writeln('MAX = ',max);
end.
Сумма цифр массива
Найти сумму всех цифр целочисленного массива. Например, если дан массив [12, 104, 81], то сумма всех его цифр будет равна 1 + 2 + 1 + 0 + 4 + 8 + 1 = 17.
Найти сумму элементов между минимальным и максимальным элементами массива
В одномерном массиве найти сумму элементов, находящихся между минимальным и максимальным элементами. Сами минимальный и максимальный элементы в сумму не включать.
Среднее арифметическое положительных элементов массива
Найти среднее арифметическое положительных элементов линейного массива.
Максимальный отрицательный элемент массива
В массиве найти максимальный отрицательный элемент. Вывести на экран его значение и позицию в массиве.
Число, чаще всего встречающееся в массиве
Определить, какое число в массиве встречается чаще всего.
Поменять местами минимальный и максимальный элементы
В массиве случайных целых чисел поменять местами минимальный и максимальный элементы.
Сдвиг массива
Сдвинуть элементы массива в указанном направлении (влево или вправо) и на указанное число шагов. Освободившиеся ячейки заполнить нулями. Выводить массив после каждого шага.
Вывести неповторяющиеся элементы массива
В массиве найти элементы, которые в нем встречаются только один раз, и вывести их на экран. То есть найти и вывести уникальные элементы массива.
Реверс массива
Переставить элементы заданного массива в обратном порядке, то есть произвести реверс массива.
Найти наибольший элемент и его порядковый номер в массиве
Заполнить одномерный массив случайными числами. Найти и вывести на экран наибольший его элемент и порядковый номер этого элемента.
Сколько элементов массива больше по модулю максимального
Создать массив из 20 элементов в диапазоне значений от -15 до 14 включительно. Определить количество элементов по модулю больших, чем максимальный.
Удаление отрицательных элементов массива
Заполнить массив случайными положительными и отрицательными целыми числами. Вывести его на экран. Удалить из массива все отрицательные элементы и снова вывести.
Определить индексы четных элементов массива
Во втором массиве сохранить индексы четных элементов первого массива. Например, если дан массив со значениями 8, 3, 15, 6, 4, 2, то во второй массив надо заполнить значениями 1, 4, 5, 6 (или 0, 3, 4, 5 - если индексация начинается с нуля), т.к. именно в этих позициях первого массива стоят четные числа.
Найти максимальный по модулю элемент в массиве с уникальными по модулю значениями
Заполнить массив случайными положительными и отрицательными числами таким образом, чтобы все числа по модулю были разными. Это значит, что в массиве не может быть ни только двух равных чисел, но не может быть двух равных по модулю. В полученном массиве найти наибольшее по модулю число.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая из двух чисел, одно из которых — чётное, а другое — нечётное, определяет и выводит на экран нечётное число.
program raf105;
var a,b: integer;
begin
write('введите 2 числа через пробел: ');
readln(a,b);
if (a mod 2)< > 0
then writeln('нечётное: ',a)
else writeln('нечётное: ',b);
end.
язык pascalabc